Jump to:

2082 Posts in 1002 Topics by 452 members

E-Commerce Modules

SilverStripe Forums » E-Commerce Modules » Product Names not being displayed on Checkout page

Discuss about the various e-commerce modules available:
Ecommerce, SS Shop, SilverCart and SwipeStripe
Alternatively, have a look the shared mailinglist.

Moderators: martimiz, Nicolaas, Sean, frankmullenger, biapar, Willr, Ingo, Jedateach, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1279 Views
  • vamsee007
    Avatar
    Community Member
    4 Posts

    Product Names not being displayed on Checkout page Link to this post

    Hi, I have installed the latest version of Silverstripe 2.3.2 and E-Commerce module 0.5.2
    I have a problem on the Checkout page. When the Product is added to the cart and checkout option is pressed, the Product name is not being displayed, and eventually when the purchase is made (Cheque is the only option), the email gets sent out without any product name details.

    Try here
    http://www.advancediagnostics.co.nz/cms/

    Has any one faced this issue in the past? Any resolutions or suggestions would be very helpful.

    Thank you

  • vamsee007
    Avatar
    Community Member
    4 Posts

    Re: Product Names not being displayed on Checkout page Link to this post

    From the above - I also would like to remove the Country option on the check out process, or make it as Static to New Zealand only, since I am not going to use any other country, can anyone suggest on how this is possible?

    Thank you v much.

  • runnerman
    Avatar
    Community Member
    24 Posts

    Re: Product Names not being displayed on Checkout page Link to this post

    Ecommerce version 0.5.2 is not compatible with the latest versions of silverstripe, so you will encounter a number of issues. I'm not sure if that is what is causing the product names to not be displayed in the checkout but it's probably not helping!

    I'd suggest upgrading to a newer version (such as the current 0.6 beta 1, available here http://silverstripe.org/e-commerce-module-forum/show/262686#post262686) and starting from there. To have less trouble with the latest version I'd also suggest upgrading silverstripe to the latest version, available here http://www.silverstripe.org/assets/downloads/SilverStripe-v2.3.3-rc2.tar.gz

    I hope this helps.

    Note: If you upgrade to the 0.6 beta version of ecommerce, make sure you install the payments module available from the same location.

  • vamsee007
    Avatar
    Community Member
    4 Posts

    Re: Product Names not being displayed on Checkout page Link to this post

    Thank you for the information, I will look into it tonight and come back to you. Once again thank you for the info.

  • vamsee007
    Avatar
    Community Member
    4 Posts

    Re: Product Names not being displayed on Checkout page Link to this post

    Thank you, that has worked now, however there is a problem with the template I am using (higherground), it does not display any products, as soon as I change the template to blackcandy, all works good.

    Any reason ?

    Does the new version not support the old templates ?

  • supermegaultra
    Avatar
    Community Member
    33 Posts

    Re: Product Names not being displayed on Checkout page Link to this post

    What version of SilverStripe does eCommerce 0.5.1 beta work best with?

    I'm having this same problem and I don't want to upgrade to the latest beta build of the eCommerce module, as the way the featured products and non-featured products are handled on parent pages is a real neucence.

    Any thoughts?

    1279 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.