1779 Posts in 582 Topics by 556 members
|Go to End|
19 April 2010 at 9:33pm
i am trying to run mollom and spamprotection (->userforms). i did all the steps in the documentation. after doing dev/build everything seems nice an clear. when i am trying to add the Field in the CMS: SpamProtection Field i get in the frontend this error:
Fatal error: Class MollomSpamProtector contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (SpamProtector::getFieldName) in /www/htdocs/w00c6fac/cms-holzmanufaktur/mollom/code/MollomSpamProtector.php on line 54
i am not shure what this mean. i looked up to the line 54 and discovered just an closing } maybe the problem is somewhere within the code?
but what is missing? and how can i fix it?
thanks for your support.
22 April 2010 at 10:13pm
This is a new issue with Mollom in the trunk causing this on our sites in SilverStripe 2.3 too. I haven't tried it, but I imagine Mollom on 2.4 works like a charm.
We're now locking Mollom to a previous revision using Subversion. In our externals, we use:
mollom/ -r 103334 http://svn.silverstripe.com/open/modules/mollom/trunk/
Hope this helps,
23 April 2010 at 8:47pm
Yep just to confirm - Mollom is being updated to work with 2.4. To use it on 2.3 please lock to a revision or use a branch/tag that has been created for it.
We'll be releasing a sweeping list of module updates for 2.4 compatibility soon. If there is no release (branch or tag) which works on 2.3 please get in touch with the module developers and they can organize to maintain a 2.3 only branch if thats appropriate. With Mollom I can't think too much of the APIs in 2.4 which would break it.
23 April 2010 at 8:53pm
Yes, we have locked our 2.3 sites to tags for mollom now.
But the 0.2 tag seems to have a lot of missing changes since r103334.
Are there plans to push the latest code that works with 2.3 into a new tag?
26 April 2010 at 8:34pm Last edited: 26 April 2010 8:36pm
thank you for your help and your suggestions. by the way i solved my problem with recaptcha and Silverstrive-v.2.3.5.
i need to degrate my installation from 2.3.7 to 2.3.5. that was really disappointing me.
if somebody else has these problem be sure that you are using the version wich ist required.
all modules need to fit in! these combination of modules is very sensitive to run!
|Go to Top|