Jump to:

1970 Posts in 1275 Topics by 607 members

Form Questions

SilverStripe Forums » Form Questions » Drag fields not dragging in user defined forms

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 366 Views
  • finfr244
    Avatar
    Community Member
    2 Posts

    Drag fields not dragging in user defined forms Link to this post

    Ok, I've trawled through a few problems about this very topic and no one, to my knowledge, has found a solid fix to it. Basically I have a user defined form on my silverstripe site and when I create my fields and then drag them it doesn't let me. However if I refresh my browser I can then drag and drop my fields to where ever I want. Is there any way this can work with a browser refresh?

  • Willr
    Avatar
    Forum Moderator
    5462 Posts

    Re: Drag fields not dragging in user defined forms Link to this post

    The reason why drag and drop doesn't work is the fact that the events aren't binded correctly to the DOM nodes. There are some fixes in master for it (rather than 0.2 release) and a couple more changes I've yet to push as still discovering edge cases in some browsers.

  • finfr244
    Avatar
    Community Member
    2 Posts

    Re: Drag fields not dragging in user defined forms Link to this post

    Cool, thanks for that Will.

    366 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.