Jump to:

1016 Posts in 567 Topics by 309 members

Forum Module

SilverStripe Forums » Forum Module » Question on 0.3 and new features

Discuss the Forum Module.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 645 Views
  • mattclegg
    Avatar
    Community Member
    56 Posts

    Question on 0.3 and new features Link to this post

    Hi Willr,

    Firstly, great work on the Forum Module. I've heard some people call it a hack, but it meets an important need for many websites. Are there anyplans in the future to implement a feature similar to 'Facebook like' or 'reddit upvote' to individual posts or threads? As I think this would be a great improvement to any web community.

    And, does the latest 0.3 (trunk) work correctly with multipul forum holders at different sub URLS? IE using a site tree containing the pages;
    website.com/topic/category/ForumHolder
    website.com/topic/categorys/anothercategory/what_anothercategery/yes_anothercategory/goshthatsalongurl/ForumHolder

    Matt

  • Willr
    Avatar
    Forum Moderator
    5462 Posts

    Re: Question on 0.3 and new features Link to this post

    'Liking' or voting threads isn't on the horizon but I'm happy to help anyone who wants to implement such a thing.

    You can only have Forum Holder -> Category -> Forum. I wouldn't think nested forum holders work.

    Most of the issues with the current forum will be fixed for the 1.0 release. Aim is to give forum a solid, robust platform to which extend later on the current forum has some things thats always annoyed people.

  • WalterW
    Avatar
    Community Member
    17 Posts

    Re: Question on 0.3 and new features Link to this post

    The new version is not working with our MySQL server. Using dev/build, we get errors in Forum.php line 67

             "SELECT * FROM \"Permission\" WHERE \"GroupID\" = '$forumGroup->ID' AND \"Code\" LIKE '$code'")

    This is a wrong code for our MySqlServer, he does not like the " around Permission, GroupId and Code.
    If I change the statement to

             "SELECT * FROM Permission WHERE GroupID = '$forumGroup->ID' AND Code LIKE '$code'")

    /dev/build is working

    But I think the quotes are necessary for PostgreSQL etc.
    Have we to change some setting of our MySQL-Server?

  • Willr
    Avatar
    Forum Moderator
    5462 Posts

    Re: Question on 0.3 and new features Link to this post

    @WalterW - Do you get errors from the site in general about the query escaping (we use it throughout sapphire so it would be strange that it only complained about the quotes in the forum). Note for that to work you'll have to be using SS 2.4

    645 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.