Jump to:

1036 Posts in 810 Topics by 315 members

Forum Module

SilverStripe Forums » Forum Module » Forum 0.2.0 and SS 2.3.3

Discuss the Forum Module.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 2396 Views
  • Bruce B
    Avatar
    Community Member
    145 Posts

    Forum 0.2.0 and SS 2.3.3 Link to this post

    I have Forums running happily under 2.3.2. I loaded 'cms', 'jsparty' and 'sapphire' from 2.3.3 and then ran dev/build/?flush=1

    All I got was a PHP error:
    PHP Fatal error: Using $this when not in object context in . . . /forum/code/ForumRole.php on line 85
    Reverting back to 2.3.2 fixed the problem.

    Can someone confirm that the Forum module is OK in their set up under 2.3.3?

  • jmperea
    Avatar
    Community Member
    5 Posts

    Re: Forum 0.2.0 and SS 2.3.3 Link to this post

    I have the same problem.

    bye

  • jmperea
    Avatar
    Community Member
    5 Posts

    Re: Forum 0.2.0 and SS 2.3.3 Link to this post

    Hello:

    I have installed forum-trunk-r81880.tar.gz, and now is ok.

    Try it.

    bye

  • BruceG
    Avatar
    Community Member
    29 Posts

    Re: Forum 0.2.0 and SS 2.3.3 Link to this post

    I installed the trunk version and got as far as posting the first post and this error occurred

    Fatal error: require_once() [function.require]: Failed opening required 'HTML/BBCodeParser/Filter.php' (include_path='./:/usr/local/lib/php:/usr/share/pear/:/usr/local/apache/phpinc/:/home/afsmanawatu/afsm.org.nz/') in /home/afsmanawatu/afsm.org.nz/sapphire/parsers/HTML/BBCodeParser/Filter/Basic.php on line 31

    So the post exists but I can't open it and get the above instead.

  • Bruce B
    Avatar
    Community Member
    145 Posts

    Re: Forum 0.2.0 and SS 2.3.3 Link to this post

    I have installed forum-trunk-r81880 and just confirmed that all the basic functionality seems to be working - create new topic, reply to a topic and editing a topic.

  • Willr
    Avatar
    Forum Moderator
    5508 Posts

    Re: Forum 0.2.0 and SS 2.3.3 Link to this post

    Hey Guys,

    Thanks for this, something must have changed in 2.3.3. I will release a smaller Forum 0.3 update to address 2.3.3 compatibility before we start on the upcoming major API changes for Forum trunk.

    Cheers,
    Will

  • andrew_crosby
    Avatar
    Community Member
    5 Posts

    Re: Forum 0.2.0 and SS 2.3.3 Link to this post

    Hi Will,

    thanks for this - any idea of the timescales for this Forum 0.3 release?

  • Willr
    Avatar
    Forum Moderator
    5508 Posts

    Re: Forum 0.2.0 and SS 2.3.3 Link to this post

    an update will be released tomorrow. I will quickly review the situation tomorrow morning but it will be a 0.2.1 release for now so I will post once that has been released and download pages updated.

    2396 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.