Jump to:

23367 Posts in 18143 Topics by 2863 members

General Questions

SilverStripe Forums » General Questions » Files & images problem

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2 3
Go to End
Author Topic: 2491 Views
  • Webdoc
    Avatar
    Community Member
    332 Posts

    Re: Files & images problem Link to this post

    [Wed Jan 20 11:42:10 2010] [error] [client some ip......] File does not exist: /home/np29484/domains/rannamajad.ee/public_html/media

  • OwenW
    Avatar
    Community Member
    45 Posts

    Re: Files & images problem Link to this post

    OK, from the error log, this directory does not seem to exist..

    /home/np29484/domains/rannamajad.ee/public_html/media

    But you are sure that it does and that it has the correct permissions?

    Also have you modified code to have the assets folder located somewhere else?

    Cheers
    Owen

  • Webdoc
    Avatar
    Community Member
    332 Posts

    Re: Files & images problem Link to this post

    but this isnt the right folder in error log strange that it dont show also if i use ?devis=1

    the right assets folder is folder assets not media in clean isntall there is not folder named media.
    isit possible that the error is because of some earlier script who writed the mod like joomla what uses the media folder for pictures.

    if its so how to clean it up.

    or the wordpress what was installed there earlier also

  • Webdoc
    Avatar
    Community Member
    332 Posts

    Re: Files & images problem Link to this post

    in ftp i dont have the media folder i have only the ss 2.4 alpha 1 files. no modules installed for it.

  • Webdoc
    Avatar
    Community Member
    332 Posts

    Re: Files & images problem Link to this post

    after i use the button upload the files the error comes up like in attachment

    Attached Files
  • OwenW
    Avatar
    Community Member
    45 Posts

    Re: Files & images problem Link to this post

    Try creating a media folder over FTP then see if that solves the problem

    Its not quite normal behavior to have the assets sitting in a media folder, but im wondering if its not related to the translation that you have going on..

    Also, can you put your system in to dev mode by putting the following in mysite/_config.php to get a bit more information out of silverstripe.

    Director::set_environment_type('dev');

    Cheers

  • Webdoc
    Avatar
    Community Member
    332 Posts

    Re: Files & images problem Link to this post

    [Notice] Undefined variable: fullFilename
    POST /admin/assets/UploadForm
    Line 204 in /home/np29484/domains/rannamajad.ee/public_html/sapphire/filesystem/Folder.php

    Source
    195          $file = ereg_replace('[0-9]*(\.[^.]+$)',$i . '\\1', $file);
    196          if($oldFile == $file && $i > 2) user_error("Couldn't fix $file with $i", E_USER_ERROR);
    197       }
    198       
    199       if (move_uploaded_file($tmpFile['tmp_name'], "$base/$file")) {
    200          // Update with the new image
    201          return $this->constructChild(basename($file));
    202       } else {
    203          if(!file_exists($tmpFile['tmp_name'])) user_error("Folder::addUploadToFolder: '$tmpFile[tmp_name]' doesn't exist", E_USER_ERROR);
    204          else user_error("Folder::addUploadToFolder: Couldn't copy '$tmpFile[tmp_name]' to '$fullFilename'", E_USER_ERROR);
    205          return false;
    206       }
    207    }
    208    
    209
    210    //-------------------------------------------------------------------------------------------------
    Trace
    •Folder->addUploadToFolder(Array)
    Line 217 of AssetAdmin.php
    •AssetAdmin->doUpload(Array,Form,SS_HTTPRequest)
    Line 292 of Form.php
    •Form->httpSubmission(SS_HTTPRequest)
    Line 135 of RequestHandler.php
    •RequestHandler->handleRequest(SS_HTTPRequest)
    Line 152 of RequestHandler.php
    •RequestHandler->handleRequest(SS_HTTPRequest)
    Line 150 of Controller.php
    •Controller->handleRequest(SS_HTTPRequest)
    Line 282 of Director.php
    •Director::handleRequest(SS_HTTPRequest,Session)
    Line 127 of Director.php
    •Director::direct(/admin/assets/UploadForm)
    Line 122 of main.php

  • Webdoc
    Avatar
    Community Member
    332 Posts

    Re: Files & images problem Link to this post

    this is the error

    2491 Views
Page: 1 2 3
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.