Jump to:

23001 Posts in 11702 Topics by 2827 members

General Questions

SilverStripe Forums » General Questions » [SOLVED] Sitemap ~~ Ghost ~~

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 539 Views
  • steve_nyhof
    Avatar
    Community Member
    224 Posts

    [SOLVED] Sitemap ~~ Ghost ~~ Link to this post

    I haven't run into this before, but I have a Sitemap next to my Home page nav button that does not exist anywhere.

    I did install the RockMap, but uninstalled it along with every other mention of the Sitemap.ss and .php files that I had in the files. I also went to the db and deleted every record of all the _versions tables.

    Then I did an install.php - but there it still is...

    Anyone run into this or have an idea how to remove it?

    And no, it does not exist in the site tree in admin or page dropdown.

    Did the dev/build - did the /?flush=1 - nothing

  • steve_nyhof
    Avatar
    Community Member
    224 Posts

    Re: [SOLVED] Sitemap ~~ Ghost ~~ Link to this post

    Ok, so it was not a ghost! It was in fact a sitemap page (nothing on it), but moved into a sub folder without saving which made it look like it should be in the main navigation where it was showing up. Once deleted, it was gone.

    Good lessen to anyone wondering why a page shows up in one place when located in another - chances are, you moved it, took a phone call and forgot to save the new location.

    Move your page and Save it.

    539 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.