Jump to:

23456 Posts in 18905 Topics by 2877 members

General Questions

SilverStripe Forums » General Questions » SS 2.4 beta2. PostgreSQL and UserForms

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 2128 Views
  • nomen
    Avatar
    Community Member
    52 Posts

    SS 2.4 beta2. PostgreSQL and UserForms Link to this post

    Hi all:

    I´m doing some testing on SS 2.4 beta2 with PostgreSQL.
    Installation goes OK.
    To add user forms I downloaded the module.
    After the dev/build , apparently all went well, but I read somewhere that needed to upgrade to the latest version of user forms to make it work SS2.3 or higher. So, I downloaded latest trunk (userforms-trunk-r100973).
    The dev/build gives me an error renaming a table.
    I think in PostgreSQLDatabase.php function renameTable, the line:
    $this->query("ALTER TABLE \"$oldTableName\" RENAME \"$newTableName\"");
    should be
    $this->query("ALTER TABLE \"$oldTableName\" RENAME TO \"$newTableName\"");

    OK. This solve the problem for me. Now dev/build is OK.
    Then I make dev/tasks/UserFormsMigrationTask with no problems.
    The problem is that, in admin panel, I can´t see the new PageType: 'User Defined Form'.

    Any idea about this?

  • motly
    Avatar
    Community Member
    4 Posts

    Re: SS 2.4 beta2. PostgreSQL and UserForms Link to this post

    I think I get a similar issue too. (2.4.0-beta2, mysql)

    In the CMS admin if I click on any "UserDefinedForm" page I get a javascript alert pop up with the source of my "Page not found" page. After clicking OK on the alert box i get a red "error loading page" message in the CMS.

    In the draft/published versions the user defined forms work fine.

    Any help appreciated.

  • nomen
    Avatar
    Community Member
    52 Posts

    Re: SS 2.4 beta2. PostgreSQL and UserForms Link to this post

    Maybe there are two errors....
    First of them is related to Postgres, where is not correctly added UserDefinedForm to database.
    The second one is creating a new User Defined Form.
    ¿Maybe it is not tested User Defined Forms in SS 2.4 beta2?

    I have open a tickep for the problem of renaming table http://open.silverstripe.org/ticket/5241

  • nomen
    Avatar
    Community Member
    52 Posts

    Re: SS 2.4 beta2. PostgreSQL and UserForms Link to this post

    Definitively something is bad with PostgreSQL and UserForms.
    I have create a MySQL based project with 2.4.beta2 and installed UserForms without problems...
    I will continue with this because my client needs PostgreSQL but I´m lost...

  • Geoff
    Avatar
    Core Development Team
    8 Posts

    Re: SS 2.4 beta2. PostgreSQL and UserForms Link to this post

    Hi everyone,

    I have just committed a large number of fixes for modules running on the 2.4 branch of SilverStripe. These fixes specifically addressed Postgres support issues.
    I've taken a quick look at the user forms module, and it appears to work.

    Thanks,
    Geoff

  • nomen
    Avatar
    Community Member
    52 Posts

    Re: SS 2.4 beta2. PostgreSQL and UserForms Link to this post

    It does not work for me.
    Some info:

    • PHP 5.1.6
    • Postgres 8.3
    • postgresql-trunk-r101403
    • userforms-trunk-r101443

    I install a clean SS 2.4 in PostgreSQL.
    I add userforms, run www.misite.com/dev/build and see messages from database table creation with no errors.
    In admin, I can´t see User Defined Forms in page type.
    Could be a problem with the PHP version? I will try to test it in another server...

  • Geoff
    Avatar
    Core Development Team
    8 Posts

    Re: SS 2.4 beta2. PostgreSQL and UserForms Link to this post

    There may be some issues with PHP 5.1.6. If you get this working on another version (5.3 for instance) then please let us know and we'll see where the problem is.

    Geoff

  • nomen
    Avatar
    Community Member
    52 Posts

    Re: SS 2.4 beta2. PostgreSQL and UserForms Link to this post

    Hi all:
    I try to install SS in Fedora 12 to test it.
    The problem is that I cant install it.
    The installer stops without errors (I only can read "PHP 5 is required" in page title):

    I am now running through the installation steps (this should take about 30 seconds)

    If you receive a fatal error, refresh this page to continue the installation

    * Setting up 'mysite/_config.php'...
    * Setting up /var/www/html/ss24fedora/mysite/_config.php
    * Building database schema...

    Environment:
    - SS 2.4.0 beta 2
    - Postgres module: postgresql-trunk-r101736.
    - Apache 2.2.14
    - PHP 5.3.2
    - Postgres 8.3 working in a remote server.
    - SE linux disabled
    - I have create the silverstripe-cache directory. It works because there are files created.
    - gd2, mysql, hash, mbstring modules loaded
    .httacces files are in their place.
    Directory config is:

    <Directory /var/www/html/ss24fedora>
       Options FollowSymLinks SymLinksifOwnerMatch
    Options All
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>


    Any idea what Iḿ doing bad?

    2128 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.