Jump to:

23483 Posts in 18976 Topics by 2878 members

General Questions

SilverStripe Forums » General Questions » DataobjectManager Backend site-content problem

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 804 Views
  • SSadmin
    Avatar
    Community Member
    90 Posts

    DataobjectManager Backend site-content problem Link to this post

    Hey, Folks,

    i recently encountered a problem with DataObjectManager. Just get quite frustrating some time.

    The problem is, i am using DataObjectManager in my homepage to lists several homeproducts.

    I did the code followed carefully with tutorial.

    Create HomePage.php
    Create HomeProduct.php
    and adding some logic there.

    In the end, the dataobjectmanager was actually works fine.
    just the site-content left hand side-site tree structure looks weird.
    once i created a new record in throung dataobject manager, it will auto creat a blank page under the homepage . i don't want to the subpages shown there. they looks strange, as u can see from the screenshot i posted. (the site-tree on lefthand side)
    By the way. i am running the lastes ss 2.3.7, but another website i got using 2.3.6 for the same feature seems work fine

    is there anybody know what could possiblely go wrong there?!

    The code has been attached if anyone got time to have a look.

    Thanks in advanced, really appreciated.

    804 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.