Jump to:

23376 Posts in 18295 Topics by 2867 members

General Questions

SilverStripe Forums » General Questions » Ubuntu 10.04

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 2905 Views
  • Mo
    Avatar
    Community Member
    505 Posts

    Ubuntu 10.04 Link to this post

    Anyone on here running SIlverstripe on Ubuntu 10?

    I am getting a really weird error, on a new Ubuntu 10 VPS I have setup. Basically, I cannot access /admin/cms/, it just sits on the loading screen and hangs.

    No error are generated anywhere, not in the server logs, php logs, Silverstripe logs. Firebug doesn't reveal much either.

    This is a site I have upgraded from 2.3 to 2.4, but it runs on my local MAMP server fine, both pre and post upgrade.

    All other CMS functionality works fine.

    Any ideas?

    Mo

  • Mo
    Avatar
    Community Member
    505 Posts

    Re: Ubuntu 10.04 Link to this post

    In terms of the Javascript errors, I am getting these:

    cms:1555Unmatched </div> encountered. Ignoring tag.
    LeftAndMain.js:186Uncaught TypeError: Cannot read property 'height' of undefined
    iframe:5Unmatched </base> encountered. Ignoring tag.
    iframe:5Unmatched </base> encountered. Ignoring tag.
    iframe:5Unmatched </base> encountered. Ignoring tag.
    prototype.js:1100Uncaught TypeError: Cannot call method 'match' of undefined
    LeftAndMain.js:186Uncaught TypeError: Cannot read property 'height' of undefined
    LeftAndMain.js:769Uncaught TypeError: Cannot set property 'display' of undefined
    7editor_plugin_src.js:86Uncaught TypeError: Object #<an Object> has no method 'respondToNodeChange'
    prototype.js:345Uncaught TypeError: Cannot call method 'split' of undefined
    Refused to set unsafe header "Connection"
    jquery.ondemand.js:177Uncaught TypeError: Object function ( selector, context ) {
       // The jQuery object is actually just the init constructor 'enhanced'
       return new jQuery.fn.init( selector, context );
    } has no method 'processOnDemandHeaders'
    Refused to set unsafe header "Connection"
    jquery.ondemand.js:177Uncaught TypeError: Object function ( selector, context ) {
       // The jQuery object is actually just the init constructor 'enhanced'
       return new jQuery.fn.init( selector, context );
    } has no method 'processOnDemandHeaders'
    Refused to set unsafe header "Connection"
    jquery.ondemand.js:177Uncaught TypeError: Object function ( selector, context ) {
       // The jQuery object is actually just the init constructor 'enhanced'
       return new jQuery.fn.init( selector, context );
    } has no method 'processOnDemandHeaders'

    Some don't look to nice, I don't know enough about all of SilverStripes ajax stuff to make head nor tails of them to be honest.

    Mo

  • biapar
    Avatar
    Forum Moderator
    435 Posts

    Re: Ubuntu 10.04 Link to this post

    Permission on folder?

    I've used Ubuntu 9.04 and Win2k8 IIS 7.5 WinCache ( now ) without problems..

  • mark_s
    Avatar
    Community Member
    78 Posts

    Re: Ubuntu 10.04 Link to this post

    Hi.

    I have 2.4 running fine on Ubuntu 10.04.

    Have you made sure that sapphire and cms have been replaced (i.e. 2.3 files removed, not lingering). Same goes for jsparty, which is not in 2.4 any more.

    Mark

  • Mo
    Avatar
    Community Member
    505 Posts

    Re: Ubuntu 10.04 Link to this post

    Not permissions (as far as I can tell), have tried doing a chown recursive on all files and folders, also tried running as a different user (using the mpm_itk apache module).

    All files are definatly 2.4, I use a python based deployment script that removes all of the old files before running an update.

    I am trying to get an old version of the database and try running an update again, I will post back my results. It seems very odd though :s.

    Mo

  • Mo
    Avatar
    Community Member
    505 Posts

    Re: Ubuntu 10.04 Link to this post

    Ok, I have tracked this issue to something to do with CMS Workflow (sorry, I neglected to mention I am using this).

    I have upgraded to RC4, but something is causing weirdness.

    Anyway, I think I will post a new topic under the Workflow module instead.

    Cheers for your help,

    Mo

  • jam13
    Avatar
    121 Posts

    Re: Ubuntu 10.04 Link to this post

    Lucid is PHP 5.3, is SilverStripe fully compatible with 5.3 (including all the modules)?

    I've had to pull in php libs from Karmic on my dev box as quite a few of the libs that I'm using are not compatible.

  • Mo
    Avatar
    Community Member
    505 Posts

    Re: Ubuntu 10.04 Link to this post

    Interesting, I didn't know that.

    Wouldn't a compatibility problem raise an error, either from PHP or Apache though?

    Mo

    2905 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.