Jump to:

23459 Posts in 18906 Topics by 2877 members

General Questions

SilverStripe Forums » General Questions » Link problems

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 597 Views
  • Arborlow
    Avatar
    Community Member
    2 Posts

    Link problems Link to this post

    A questiion from a newbie, its been a steep learning curve but I'm begining to understand and am liking how SS works. Ive done basic html sites before but nothing like SS.

    I've got some html pages from an old site that I want to link from a page in SS for the time being. The pic files and html file are in a directory on the same root as SS. I have used the create link button and written the html myself but am unable to get a link. Surely it is possible to do such a simple link to other pages. I'm confused.

    Cheers

  • mattclegg
    Avatar
    Community Member
    56 Posts

    Re: Link problems Link to this post

    You might be getting the problem because Silverstripe manages its internal links in quite an integeral way (which is good for site reporting and backlinking etc)

    Try using "Link -> Another website" and use the full 'external link' URL. ie http:://mydomain.com/oldpages/oldpage1.htm as the files are external to the PHP Framework.

  • Arborlow
    Avatar
    Community Member
    2 Posts

    Re: Link problems Link to this post

    Thanks for the quick reply. I didn't need to use the whole http address but your prompting made me look at the bottom left hand corner of the browser and I removed the .. from my ../mydir/ and everthing is good. It just needed another perspective to work it out

    Cheers

    597 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.