Jump to:

23355 Posts in 17744 Topics by 2862 members

General Questions

SilverStripe Forums » General Questions » tinyMCE keeps turning my Quicktime videos into broken Flash Objects

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1763 Views
  • Vertigo187
    Avatar
    Community Member
    1 Post

    tinyMCE keeps turning my Quicktime videos into broken Flash Objects Link to this post

    I am using SilverStripe 2.4.1. It doesn't seem to matter what I do tinyMCE always strips my quicktime videos down to a flash object. I have a client that insists that his videos be Quicktime for the iPhone and iPad. As you can see below I've added the media plugin, and it doesn't matter if I add it through that or HTML.

    This is the code I'm trying to put in:

    <object classid="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B"
    codebase="http://www.apple.com/qtactivex/qtplugin.cab" width="540" height="376" >
    <param name="src" value="assets/movs/AU-3.mov" >
    <param name="autoplay" value="true">QuickTime Movie
    <embed src="assets/movs/AU-3.mov" type="image/x-macpaint"
    pluginspage="http://www.apple.com/quicktime/download" width="540" height="376" autoplay="true">QuickTime Movie</embed>
    </object>

    If I add it via HTML and than reopen the HTML window it's stripped to this:

    <object width="540" height="376">
    <param name="src" value="assets/movs/AU-3.mov"/>
    <param name="autoplay" value="true"/>
    <embed type="video/quicktime" width="540" height="376" src="assets/movs/AU-3.mov" autoplay="true"/>
    </object>

    If I add it via the media plugin and open up the HTML there is this:

    <object width="540" height="376">
    <param name="src" value="assets/movs/AU-3.mov" /><embed type="video/quicktime" width="540" height="376" src="assets/movs/AU-3.mov">&nbsp;</embed>
    </object>

    As soon as I hit save and publish it turns into flash object. With the proceeding HTML being what's live and if I save again or look at the HTML it's reduced to this:

    <object width="540" height="376" data="assets/movs/AU-3.mov" type="application/x-shockwave-flash">
    <param name="src" value="assets/movs/AU-3.mov" />
    </object>

    I have tried everything I can find on the forum. These are all the different settings in the /mysite/_config.php I've tried:

    HtmlEditorConfig::get('cms')->setOption('apply_source_formatting', 'false');
    HtmlEditorConfig::get('cms')->setOption('verify_html', 'false');
    HtmlEditorConfig::get('cms')->setOption('valid_elements', 'all the elements needed plus what ever is used throughout the site ');

    HtmlEditorConfig::get('cms')->enablePlugins('../sapphire/thirdparty/tinymce/plugins/media');
    HtmlEditorConfig::get('cms')->insertButtonsAfter('charmap', 'media');

    Please let me know if you have any insight as to why it is behaving like this. This is really frustrating. Thanks

  • wmk
    Avatar
    Community Member
    45 Posts

    Re: tinyMCE keeps turning my Quicktime videos into broken Flash Objects Link to this post

    Yes, this is very frustrating. Same here, SS 2.4.1 and the embed code for adding a mms url is stripped all the time.

    I noticed, that it's saved right one time, on reloading the page SS sends the original code including <embed>, but tinymce somehow seems to strip the <embed> out of the code. Annoying.

    And yes, i enabled the media plugin and added embed to extended_valid_elements

    Anyone a hint?

  • Hankster
    Avatar
    Community Member
    14 Posts

    Re: tinyMCE keeps turning my Quicktime videos into broken Flash Objects Link to this post

    I hate to bring up an old thread, but I'm wondering whether anyone got this working? I, too, would like to embed a quicktime file into my website. I'm using 2.4.5

  • ignaciorvc
    Avatar
    Community Member
    1 Post

    Re: tinyMCE keeps turning my Quicktime videos into broken Flash Objects Link to this post

    Hi - I'm pretty much a newbie - and am having the same problem. I'm using 2.4.5, has anyone come across a fix to embed quicktimes?

  • Gemmelai
    Avatar
    Community Member
    3 Posts

    Re: tinyMCE keeps turning my Quicktime videos into broken Flash Objects Link to this post

    Hi

    I need my video in mp4 or .mov format in order for it to be viewable in apple devices.
    Does anyone know how to do this, desperately need help!

    Thanks in advance

    1763 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.