Jump to:

23007 Posts in 11866 Topics by 2828 members

General Questions

SilverStripe Forums » General Questions » Translated content -> Page blank

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 666 Views
  • oleze
    Avatar
    Community Member
    64 Posts

    Translated content -> Page blank Link to this post

    When I click on my "show this page in English" button, I get only blank pages. My German translations (standard) are working fine.
    PHP Logs the following error:

    [07-Aug-2010 19:50:17] PHP Fatal error: Call to a member function XML_val() on a non-object in /private/var/folders/zi/ziF2WYoKHjuWeyujYsvSBU+++TI/-Tmp-/silverstripe-cache-Users-username-Sites-project/.cache.Users.username.Sites.project.themes.themename.templates.Page.ss on line 119

    But because there are layoutspecific details and includes, there is no line 119 on Page.ss

  • swaiba
    Avatar
    Forum Moderator
    1769 Posts

    Re: Translated content -> Page blank Link to this post

    What version of SS are you using and is it in "dev" mode?
    I've been having strange errors with the word cache in lately - they all disappear once the site is "live".

  • oleze
    Avatar
    Community Member
    64 Posts

    Re: Translated content -> Page blank Link to this post

    I'm using 2.4.1 in dev-mode. Actually, I figured what's the problem. I'm using the CustomMenus Module for adding a topnavigation on my page. Seems it doesn't support the translation, when I comment it out, the pages show up. Damn.

    666 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.