Jump to:

23361 Posts in 18124 Topics by 2862 members

General Questions

SilverStripe Forums » General Questions » UserDefinedForm with 2.4.1 error

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1434 Views
  • SSadmin
    Avatar
    Community Member
    90 Posts

    UserDefinedForm with 2.4.1 error Link to this post

    Hey, folks,

    i have encounterred some problem using SS2.4.1 and UDF.
    The module can be installed very successfully, but the problem is if you go to the Form Tab in UserDefinedForm and add any new Field, it will redirect to a blank page with the url :http://www.testbed.dev/admin/EditForm.
    Run firebugs: it said an error:

    $("div.FieldEditor .MenuHolder .action").livequery is not a function
    [Break on this error] $("div.FieldEditor .MenuHolder .action").livequery('click',function() { }

    Not sure whats going wrong here.

    But the UDF defintely works fine with silverstripe 2.4.0 version .

    Dont know is there a new UDF available or not for fixing this problem?!

    Anyone have any thoughts plz feel free to speak out

    Thanks,
    Alex

  • Willr
    Avatar
    Forum Moderator
    5483 Posts

    Re: UserDefinedForm with 2.4.1 error Link to this post

    Try the latest trunk of UDF.

  • SSadmin
    Avatar
    Community Member
    90 Posts

    Re: UserDefinedForm with 2.4.1 error Link to this post

    just update to latest UDF, all works fine

    Thanks Wilr. appreciate! XD

  • pikefisher
    Avatar
    Community Member
    1 Post

    Re: UserDefinedForm with 2.4.1 error Link to this post

    Hi

    I'm new to Silverstripe and am currently exploring the system and have hit this same problem on starting my testing.

    I get this same error of a blank page when attempting to add any element to a form within UDF, choose any element, hit 'Add' and a blank page as follows::http://localhost:8888/silverstripe/admin/EditForm

    (installation on a Mac via MAMP of SilverStripe-v2.4.2.)

    I have downloaded and installed the latest UDR trunk: modules_userforms_trunk-r111476.zip and reinstalled, run the update builds and remain unable to install any form elements

    Having run through the Forum, I"m left wondering, any suggestions?

    Regards

    David

  • Willr
    Avatar
    Forum Moderator
    5483 Posts
    1434 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.