Jump to:

22976 Posts in 11667 Topics by 2826 members

General Questions

SilverStripe Forums » General Questions » pagestyle not showing up in dropdown menu

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 739 Views
  • bit99
    Avatar
    Community Member
    24 Posts

    pagestyle not showing up in dropdown menu Link to this post

    Hi,
    let me start by saying that I love this product,

    I have a problem though, I tried to create new page styles, acc. to your doc.silverstipe.. and tutorial one/two,
    - added the page( s).php to the mysite/code,
    - added the page (s) in the templates/Layout directory ,

    but,, no matter how I go back over it and redo, and try, the new pagestyles wont show up in the dropdown in the cms,
    maybe I am missing a step?

    thanks,

  • bit99
    Avatar
    Community Member
    24 Posts

    Re: pagestyle not showing up in dropdown menu Link to this post

    forgot to add that I did the flush and the dev/build,

    thanks,

  • Willr
    Avatar
    Forum Moderator
    5462 Posts

    Re: pagestyle not showing up in dropdown menu Link to this post

    When you did a dev/build did it appear green with the added record. Could you post the php file you used for it. Make sure your webserver has read permissions to the php file and perhaps use /dev/build?flush=all.

  • bit99
    Avatar
    Community Member
    24 Posts

    Re: pagestyle not showing up in dropdown menu Link to this post

    Hi Willr,

    thanks for responding so quickly,

    god damn, that was it, of course,
    I had the php folder / files at 644, changed it to 755 and it rebuilt for me,

    thanks!!!

    ps. 755 not the most secure maybe?

  • Willr
    Avatar
    Forum Moderator
    5462 Posts

    Re: pagestyle not showing up in dropdown menu Link to this post

    Hmm I would have thought 644 would work. What is your webserver running as (www-data or apache) and is it the owner of the directory. The only folders which need to be writable should be the cache folder and the assets folder. You might want to have a play around to see what works and what doesn't.

  • bit99
    Avatar
    Community Member
    24 Posts

    Re: pagestyle not showing up in dropdown menu Link to this post

    Hi Willr,
    I am absolutely not a server expert,
    but wouldnt it make sense though with 644 not working since it gives no execute permissions - only read ?
    pretty sure it's apache, and I have the silverstripe installed on an add-on domain to my hosting account (with hostmonster.com, which I think is a great place for hosting),
    it's actually installed in a subdirectory on that addon domain until I get the website complete and will then move it, maybe that caused the permissions issue,
    anyways, it works now,
    thanks,
    /Jonas

    739 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.