Jump to:

23368 Posts in 18143 Topics by 2863 members

General Questions

SilverStripe Forums » General Questions » Can't login to backend

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 4269 Views
  • clauer
    Avatar
    Community Member
    12 Posts

    Can't login to backend Link to this post

    Hi,

    When I want to login to the backend, Silverstripe shows a page with its logo and the word "loading" at the left upper corner while the status-bar shows "Ready". Nothing else happens, no backend form comes up. In dev-mode however I'm able to access the backend. Firebug reports up to 14 errors and three "500 Internal Server Error" as shown below:

    GET base.js?m=1289684800
    http://www.vision-glauben-2020.de/assets/_combinedfiles/base.js?m=1289684800
    500 Internal Server Error
    vision-glauben-2020.de
    659 B
    432ms

    GET leftandmain.js?m=1289684801
    http://www.vision-glauben-2020.de/assets/_combinedfiles/leftandmain.js?m=1289684801
    500 Internal Server Error
    vision-glauben-2020.de
    659 B
    375ms
       
    GET cmsmain.js?m=1289684802
    http://www.vision-glauben-2020.de/assets/_combinedfiles/cmsmain.js?m=1289684802
    500 Internal Server Error
    vision-glauben-2020.de
    659 B
    643ms

    Class ss.i18n not defined
    [Break on this error] if(typeof(console) != 'undefined') console.error('Class ss.i18n not defined');\n
    en_US....2683844 (Zeile 2)
    Class ss.i18n not defined
    [Break on this error] console.error('Class ss.i18n not defined');\n
    de_DE....3000086 (Zeile 2)
    Class ss.i18n not defined
    [Break on this error] if(typeof(console) != 'undefined') console.error('Class ss.i18n not defined');\n
    en_US....8491736 (Zeile 2)
    Class ss.i18n not defined
    [Break on this error] console.error('Class ss.i18n not defined');\n
    de_DE....6847120 (Zeile 2)
    jQuery is not defined
    [Break on this error] })(jQuery);
    Silver...8282238 (Zeile 35)
    Class is not defined
    [Break on this error] ToolbarForm = Class.create();
    tiny_m...0021050 (Zeile 1)
    jQuery is not defined
    [Break on this error] })(jQuery);
    jquery...8274558 (Zeile 665)
    jQuery is not defined
    [Break on this error] })(jQuery);
    HtmlEd...4715798 (Zeile 81)
    Behaviour is not defined
    [Break on this error] Behaviour.addLoader(hideLoading);
    admin (Zeile 550)
    Behaviour is not defined
    [Break on this error] Behaviour.register({
    admin (Zeile 645)
    Behaviour is not defined
    [Break on this error] Behaviour.register({
    admin (Zeile 701)
    Behaviour is not defined
    [Break on this error] Behaviour.register({
    admin (Zeile 757)
    Behaviour is not defined
    [Break on this error] Behaviour.register({
    admin (Zeile 774)
    Behaviour is not defined
    [Break on this error] Behaviour.register({
    admin (Zeile 836)

    All files are existing and in their right places.

    Silverstripe v243, no plugins, hosted web space (Linux / Apache 2.2 / PHP 5.3)

    Any help is appreciated, thanks so far!
    Chris

  • SilverRay
    Avatar
    Community Member
    167 Posts

    Re: Can't login to backend Link to this post

    I have the exact same problem. All of a sudden. With a plain vanilla install of 2.4.3. If I put Director::set_environment_type("dev"); in my config, it works again. When I take it out, not anymore. This is in a server environment where I never had any problems like that, with whatever version of SilverStripe. I might revert back to 2.4.2...

    Any other people experiencing this? I tried a lot of things, including changing permissions etc. but to no avail. I also see that this subject popped up before in the forums...

  • Ricdiculous
    Avatar
    Community Member
    4 Posts

    Re: Can't login to backend Link to this post

    Ditto, complete newbie to SilverStripe (but have installed and used other CMS's) Fresh download and install went so well I couldn't believe it! Well done SilverStripe. Edited page content, FTP'd some fresh images to customise template graphics, was all going swimmingly, tweaked a css. Discovered I couldn't upload images via the CMS though, thought I'd get back to that issue. Logged out, was preparing to inform my client that it was already to play with, checked login before sending email and whammo, no entry back in! I too figured perhaps file permissions so made assets folder 777. Nope still no go. Hangs with logo and loading...

    All and any heap greatfully received. Cheers

    incidently I followed closely the video to install in a cPanel environment, and like the video did I put 'admin' in the email form field (with a better password though). So when I went to login the second time wasn't sure whether to use admin or admin@thedomain? Used a variety of combinations, maybe security has just bumped me out for a bit?

  • SilverRay
    Avatar
    Community Member
    167 Posts

    Re: Can't login to backend Link to this post

    See this thread http://www.silverstripe.org/installing-silverstripe/show/14878 for more info, possibly...

  • Ricdiculous
    Avatar
    Community Member
    4 Posts

    Re: Can't login to backend Link to this post

    Couple of Legends. Worked straight off and let me in. Learning new tricks all the time. Thank you for pointing out Sean's post. Cheers

  • Benedikt
    Avatar
    Community Member
    16 Posts

    Re: Can't login to backend Link to this post

    @Silverray
    Has the patch worked for you? For me it doesn't help.

    I have the same problem as you: I can only log into the backend when in dev mode.
    For a screenshot of my Firefox error console see: http://i.imgur.com/d3iga.jpg

    I'm helpless how to fix the problem.

  • Sean
    Avatar
    Forum Moderator
    921 Posts

    Re: Can't login to backend Link to this post

    Try putting this in your mysite/_config.php file:

    Requirements::set_combined_files_enabled(false);

    Cheers,
    Sean

  • labesk
    Avatar
    Community Member
    3 Posts

    Re: Can't login to backend Link to this post

    Thanks, it works for me.

    4269 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.