Jump to:

23001 Posts in 11702 Topics by 2827 members

General Questions

SilverStripe Forums » General Questions » SLOW - profiler shows 3.5 seconds to generate html :(

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 796 Views
  • wainui
    Avatar
    Community Member
    56 Posts

    SLOW - profiler shows 3.5 seconds to generate html :( Link to this post

    Wow... over 3 seconds to generate html on a basic site....
    what is up with this???? any ideas why?

    ============================================================================
    PROFILER OUTPUT
    ============================================================================
    Calls Time Routine
    -----------------------------------------------------------------------------
    1 2256.3193 ms (69.67 %) all_execution
    7 145.3066 ms (4.49 %) obj.Children
    2 97.4419 ms (3.01 %) obj.Menu
    2 96.5133 ms (2.98 %) SSViewer::process
    14 75.1665 ms (2.32 %) obj.Link
    3 44.0280 ms (1.36 %) obj.Attachment
    1 33.6831 ms (1.04 %) DB::connect
    1 32.6760 ms (1.01 %) obj.Content
    1 21.5728 ms (0.67 %) obj.MetaTags
    19 20.7791 ms (0.64 %) obj.LinkingMode
    3 12.1000 ms (0.37 %) obj.setWidth
    2 3.4771 ms (0.11 %) obj.SideImages
    15 2.5256 ms (0.08 %) obj.Title
    14 1.5454 ms (0.05 %) obj.MenuTitle
    2 1.0281 ms (0.03 %) obj.MetaTitle
    1 0.7961 ms (0.02 %) obj.Cart
    2 0.4647 ms (0.01 %) obj.URLSegment
    1 0.2410 ms (0.01 %) obj.SiteConfig
    1 0.2179 ms (0.01 %) obj.Form
    1 0.1380 ms (0.00 %) obj.Items
    1 0.0980 ms (0.00 %) obj.CurrentMember
    1 0.0870 ms (0.00 %) obj.Layout
    1 0.0839 ms (0.00 %) main.php init
    2 0.0460 ms (0.00 %) Requirements::includeInHTML
    1 0.0181 ms (0.00 %) unprofiled

    392.0965 ms (12.11 %) Missed
    ============================================================================
    3238.4501 ms (100.00 %) OVERALL TIME
    ============================================================================

  • wainui
    Avatar
    Community Member
    56 Posts

    Re: SLOW - profiler shows 3.5 seconds to generate html :( Link to this post

    ok.. so after seraching everywhere one of tyhe things that seemed to make an immediate improvement was the commenting out the

    Director::set_dev_servers(array('localhost','127.0.0.1'));

    796 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.