Jump to:

23374 Posts in 18175 Topics by 2866 members

General Questions

SilverStripe Forums » General Questions » SOLVED - Fatal error: Class 'SS_Log' not found

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1716 Views
  • Robert Dowell
    Avatar
    Community Member
    17 Posts

    SOLVED - Fatal error: Class 'SS_Log' not found Link to this post

    I've up graded to 2.4.5, everything was working find. Now all of a sudden when I go to the site this error is shown at the bottom of the page: Fatal error: Class 'SS_Log' not found in C:\wamp\www\southeastCOsports\sapphire\dev\Debug.php on line 0
    However the site works, except when I log into the CMS and try to change anything a box pops up telling me to login and try again.

    The last thing I loaded was the Blog Module and was able to edit a blog.

    Can someone tell me how I can fix this.

    Your help is appreciated.

    Thanks,
    Bob

  • Ryan M.
    Avatar
    Community Member
    309 Posts

    Re: SOLVED - Fatal error: Class 'SS_Log' not found Link to this post

    Did you follow upgrading instructions to the letter?

    Have you tried enabling dev mode and turning on error logging to find out any more details?

  • Robert Dowell
    Avatar
    Community Member
    17 Posts

    Re: SOLVED - Fatal error: Class 'SS_Log' not found Link to this post

    Ryan

    The upgrade went as it should. This is on my local computer and the site has been working for the last two weeks. I'm not sure how to turn on dev mode or error logging.

    Thanks for your reply.

    Bob

  • Invader_Zim
    Avatar
    Community Member
    141 Posts

    Re: SOLVED - Fatal error: Class 'SS_Log' not found Link to this post

    Just add this line to your /mysite/_config.php to enable dev mode:

    Director::set_environment_type('dev');

    This should give you a much better error message.

    More here about debugging and error handling.

    Cheers
    Christian

  • Robert Dowell
    Avatar
    Community Member
    17 Posts

    Re: SOLVED - Fatal error: Class 'SS_Log' not found Link to this post

    Christian

    Thanks for your reply, however enabling dev mode didn't change the error. This is the error message I see: "Fatal error: Class 'SS_Log' not found in C:\wamp\www\southeastCOsports\sapphire\dev\Debug.php on line 0", it shows up under the footer. The site continues to work, however, when I log into the CMS (it says I'm logged in as default admin) and try to change anything a box pops up telling me to login and try again.

    I don't know why the error message didn't change. Where would I look for the error log?

    Thanks again
    Bob

  • Invader_Zim
    Avatar
    Community Member
    141 Posts

    Re: SOLVED - Fatal error: Class 'SS_Log' not found Link to this post

    Hi Robert,

    sorry, but now i'm clueless as well...

    Just to cover the obvious, do you have a file named Log.php in your /sapphire/dev/ directory?
    Have you tried a new install/upgrade?
    Are you really, really sure you haven't changed anything in these two weeks (server settings, configurations, etc.)?

    ...

    Cheers
    Christian

  • Robert Dowell
    Avatar
    Community Member
    17 Posts

    Re: SOLVED - Fatal error: Class 'SS_Log' not found Link to this post

    Christian

    Thanks for your help, I'm running WAMP on win 7 and just restarted all services, the error message went away and everything is back to normal. Sorry for the trouble.

    Again, thanks for trying to help me. As you can tell I'm pretty much a noob (if that's the right word).

    Bob

  • Ryan M.
    Avatar
    Community Member
    309 Posts

    Re: SOLVED - Fatal error: Class 'SS_Log' not found Link to this post

    Lol... when all else fails, restart the server! Usually works.

    1716 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.