Jump to:

23371 Posts in 18161 Topics by 2865 members

General Questions

SilverStripe Forums » General Questions » Security Login page doesn't exist

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1317 Views
  • Jo
    Avatar
    Community Member
    4 Posts

    Security Login page doesn't exist Link to this post

    Hi Folks

    Got a bit of a strange thing happening, the day before yesterday I could log in to my CMS without any issues, I then tried yesterday and there was no login form, ie no fields to fill in for login and password. This was solved by my replacing the '$form' in my template, but now when I login it just goes to a broken link/page that doesn't exist and I get the 404 page.

    The end of the address that it's looking for is '/Security/Security/LoginForm'.

    If you have any ideas I'd be most grateful.

    Thanks
    Jo

  • Willr
    Avatar
    Forum Moderator
    5489 Posts

    Re: Security Login page doesn't exist Link to this post

    Have you got a <% base_tag %> in your Page.ss template? Should be inside your <head> near the top.

  • barrycorrigan
    Avatar
    Community Member
    10 Posts

    Re: Security Login page doesn't exist Link to this post

    Should '$form' not be a capital F like this

    $Form

  • Jo
    Avatar
    Community Member
    4 Posts

    Re: Security Login page doesn't exist Link to this post

    Willr, you utter legend!

    Thanks so much for that response, that's fixed it up perfectly. Points too to Barry for trying!

    Cheers
    Jo

    1317 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.