Jump to:

22994 Posts in 11843 Topics by 2828 members

General Questions

SilverStripe Forums » General Questions » CHARACTER SET 'utf8' error

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 3019 Views
  • sajok
    Avatar
    Community Member
    82 Posts

    CHARACTER SET 'utf8' error Link to this post

    Hello,

    I'm using SS 2.4 and I have set the _config.php file to send errors to my email. All websites are working just fine but I frequetly receive this character set related error:

    Error: Couldn't run query: SET CHARACTER SET 'utf8'
    At line 525 in /home/perlesah/public_html/sapphire/core/model/MySQLDatabase.php

    user_error(Couldn't run query: SET CHARACTER SET 'utf8' ,256) line 525 of MySQLDatabase.php MySQLDatabase->databaseError(Couldn't run query: SET CHARACTER SET 'utf8' | ,256) line 123 of MySQLDatabase.php MySQLDatabase->query(SET CHARACTER SET 'utf8') line 60 of MySQLDatabase.php MySQLDatabase->__construct(Array) line 97 of DB.php DB::connect(Array) line 121 of main.php

    I have this in _config.php :

    MySQLDatabase::set_connection_charset('utf8');

    any idea what do to fix this?

    thanks

  • Wade
    Avatar
    Community Member
    6 Posts

    Re: CHARACTER SET 'utf8' error Link to this post

    I get this error alot as well. Anybody know anything about it?

  • AdamJ
    Avatar
    Community Member
    145 Posts

    Re: CHARACTER SET 'utf8' error Link to this post

    I've been experiencing the same error, but it appears its only when a search engine spider hits the site, normal browsing appears fine...

  • DNA
    Avatar
    Community Member
    24 Posts

    Re: CHARACTER SET 'utf8' error Link to this post

    Also getting the error, but intermittently. Currently unsure if it's because of spiders as AdamJ above.

  • AdamJ
    Avatar
    Community Member
    145 Posts

    Re: CHARACTER SET 'utf8' error Link to this post

    Has anyone found a solution to this issue? Or any SS devs care to weigh in on some possible issues at play?

  • SheaDawson
    Avatar
    Community Member
    45 Posts

    Re: CHARACTER SET 'utf8' error Link to this post

    I'm getting these error too... anyone?

  • oleze
    Avatar
    Community Member
    64 Posts

    Re: CHARACTER SET 'utf8' error Link to this post

    I'm still getting this error. Did anybody solve it?

  • sajok
    Avatar
    Community Member
    82 Posts

    Re: CHARACTER SET 'utf8' error Link to this post

    no, since I posted this thread I still receive these messages..

    3019 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.