Jump to:

23493 Posts in 18996 Topics by 2878 members

General Questions

SilverStripe Forums » General Questions » Can't upload any images, "Invalid file type" every time

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 3311 Views
  • duskydesigns
    Avatar
    Community Member
    15 Posts

    Can't upload any images, "Invalid file type" every time Link to this post

    Im trying to upload images to a live server enviroment but so far its not working. I cant upload any images, they all are invalid file type and in the lower left corner it says there's not to upload. Im not sure what the hell is wrong why im unable to get the uploads working.

    I expanded silverstripe with pixlr, uploadify, userforms, socialmedia_widget and blog.

    It could be any one of those modules, but i doubt it i think it might be something with permissions but am unsure, however right now i cannot upload any image to the server, not even with full admin priviledges.

    Im also unable to update the dir through FTP, what the hell? I got no permissions and can't set permissions wich is very frustrating. It makes the directory just not work..

    Greetings,

    Kenneth

  • swaiba
    Avatar
    Forum Moderator
    1792 Posts

    Re: Can't upload any images, "Invalid file type" every time Link to this post

    try this - even tho it says for 2.4.0 - I've needed this patch on 2.4.5 also...

    http://open.silverstripe.org/attachment/ticket/5547/2.4.0-FileUpload.diff

  • bo
    Avatar
    Community Member
    10 Posts

    Re: Can't upload any images, "Invalid file type" every time Link to this post

    Unless specified, SS won't accept JPEG-images with the extension .jpeg; only .jpg. (At least the Forum module doesn't - I haven't found the files to edit yet, so I don't know if settings are set separately.)

  • martimiz
    Avatar
    Forum Moderator
    1086 Posts

    Re: Can't upload any images, "Invalid file type" every time Link to this post

    if you can't even upload images using an ftp client, there might be something wrong with the write rights on your assets directory. Happened to me sometime, after uploading a tarred install to the live server.

    If your ftp client doesn't let you change them, and you have no shell access to the server, you might have a console that lets you do the filemanagement?

    3311 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.