Jump to:

23456 Posts in 18905 Topics by 2877 members

General Questions

SilverStripe Forums » General Questions » SSL in Admin means really slooow (often timesout)

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 415 Views
  • swaiba
    Avatar
    Forum Moderator
    1788 Posts

    SSL in Admin means really slooow (often timesout) Link to this post

    I've recently added SSL to a site and then admin area (with a left and main decorator, that redirects each request to https if just http).
    But I've had to remove it because the site loads so slooooooow and often timesout and doesn't load at all - basically unusable.

    Can anyone offer advice on whether this is "normal" or if there is something I can do to solve the situation please?

  • swaiba
    Avatar
    Forum Moderator
    1788 Posts

    Re: SSL in Admin means really slooow (often timesout) Link to this post

    ** bump **

    any help would be greatly appreciated!

  • MarcusDalgren
    Avatar
    Community Member
    288 Posts

    Re: SSL in Admin means really slooow (often timesout) Link to this post

    Can't you just set the base url to https://whatever and that fixes all other urls in the admin and on the site? The way you're doing it now you're essentially doubling all requests so of course that's very slow. I've not tried to run a site in SSL myself so I don't know but doing a redirect via decorator means that the whole stack loads before the redirect happens which is not a good thing of course.

  • MarcusDalgren
    Avatar
    Community Member
    288 Posts

    Re: SSL in Admin means really slooow (often timesout) Link to this post

    Also there's Director::forceSSL() have you tried that?

    415 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.