Jump to:

23003 Posts in 11856 Topics by 2828 members

General Questions

SilverStripe Forums » General Questions » Site homepage 404 Page not Found

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 446 Views
  • jaedb
    Avatar
    Community Member
    5 Posts

    Site homepage 404 Page not Found Link to this post

    I'm developing a website with some medium-level customisation, with out-of-the-box modules included. At some point in the development stage the homepage has gone AWOL. I am getting a 404 Page Not Found error page when I try to visit the root directory and /home pages.

    Now it gets weird.

    If I append /?flush (with or without the =1 or =all variable) the homepage works. If I empty the silverstripe-cache folder, it works once. If I delete /index.php file it works once, then it breaks. If I upload the /index.php file it works once, then it breaks.

    I have tried shifting to a different host, database repairs, moving directories, dropping a fresh install on top all without luck. Any tips would be extremely well received.

  • Willr
    Avatar
    Forum Moderator
    5464 Posts

    Re: Site homepage 404 Page not Found Link to this post

    What type of server are you setting it up on? Got any caching setup like xcache, apc?

    446 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.