Jump to:

23368 Posts in 18143 Topics by 2863 members

General Questions

SilverStripe Forums » General Questions » Performance SS3

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 1691 Views
  • hello_world
    Avatar
    Community Member
    17 Posts

    Performance SS3 Link to this post

    Why silverstripe 3 i so very,very slow, just like road roller?
    There is no comparison with eg. 2.4.7 . We have some large projects on 2.4.x and works fine.
    But SilverStripe 3.0 work like diesel engine.
    I am disappointed with the new generation Silver - everythings looks preety but that's not all.
    I suggest create new forum "Performance".

    Today we build small ecommerce solution - nothing special but I prefer not to think about how it will work on larger projects.
    Are you also experiencing this?

  • Willr
    Avatar
    Forum Moderator
    5489 Posts

    Re: Performance SS3 Link to this post

    SS3 has a rather unfortunate bug with the new config system. A patch for this is coming in 3.1.

  • Johan
    Avatar
    Community Member
    49 Posts

    Re: Performance SS3 Link to this post

    Hi Will

    Will there be a patch in the mean time? Lots of server memory being used!!!

    Thanks

  • Guy Van Bael
    Avatar
    Community Member
    32 Posts

    Re: Performance SS3 Link to this post

    Since we use SS3 in production (already 5 websites), 3 out of 5 clients complain about pages loading very slow.
    I also tested the latest 3.1 from githum, but hardly any performance improvement. Memory Limit on the hosting is 128MB, APC installed, gzip active AND using apc caching instead of file system....

    Loading times from SS2.4 were a lot better... i really hope there's improvement on the way...

  • Pix
    Avatar
    Community Member
    130 Posts

    Re: Performance SS3 Link to this post

    Same issue here. I'm glad I ran across this post as I thought I had something configured wrong. I finally took the dive into SS3 and used it on a recent site for a client. If anything, I expected the performance to be even better, but the site is much slower than a more complicated site running on the same server with SS 2.4.7 :0(

  • boon
    Avatar
    Community Member
    1 Post

    Re: Performance SS3 Link to this post

    This CMS looked interesting, but I guess I gotta look somewhere else.

    I see the latest version is 3.0.3. And this bug is supposed to be resolved in 3.1.
    How can a bug causing slowness be treated as low priority?

  • Willr
    Avatar
    Forum Moderator
    5489 Posts

    Re: Performance SS3 Link to this post

    3.1 is currently in beta and will be released as stable as soon as all the serious bugs have been ironed out. Give the beta a go and help report any issues.

  • kinglozzer
    Avatar
    Community Member
    138 Posts

    Re: Performance SS3 Link to this post

    EDIT

    Done some more profiling, results have been inconsistent so I think it's likely something on my site. Will profile both versions on a blank install in more detail when I get time.

    1691 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.