Jump to:

23552 Posts in 19349 Topics by 2891 members

General Questions

SilverStripe Forums » General Questions » /admin does not go to login page

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 823 Views
  • jrobida999
    Avatar
    Community Member
    10 Posts

    /admin does not go to login page Link to this post

    I'm sure that this question has been addressed, but I have spent the last 24 hours scouring pages and SS files trying to figure it out. Thank you for understanding my frustration.

    I am unable to access the Admin login page. I'm currently using localhost:30667/admin to try to access my CMS. It was working 2 days ago, however now it will not. dev/build, ?flush=1... everything works except getting to the admin login. I get redirected to /Security/login?BackURL=%2Fadmin%2Fpages which simply looks like my default page.

    In my research I saw a recommendation to make sure my <% base_tag %> was included in my page.ss file which it is.

    This is not a UN/PW issue as I can't even get to the login page to begin with. I tried /index.php/admin which redirected to /index.php/login?BackURL.......

    All suggestions are much appreciated. This is my first run with SS so bear with me as I learn the system/structure.

    Jake

  • jrobida999
    Avatar
    Community Member
    10 Posts

    Re: /admin does not go to login page Link to this post

    Some additional information:

    I modified Page.ss and replaced some of the lorem ipsum with $Content. After I did this I again attempted to navigate to /admin. The content I included in Page.ss populates as: "Please choose an authentication method and enter your credentials to access the CMS."

    Using this piece of info, I'm assuming that the page that content is supposed to feed into is my CMS login page, but that it is misplaced, missing, or otherwise MIA.

    Before I go digging through the documentation, does anyone know what/where that page is or should be?

    Jake

  • IOTI
    Avatar
    Community Member
    189 Posts

    Re: /admin does not go to login page Link to this post

    What version of SS? If you were to try this with a new database (just change the db name in _config.php) are you able to access the login page?

  • jrobida999
    Avatar
    Community Member
    10 Posts

    Re: /admin does not go to login page Link to this post

    Version 3.0.3

    Changing the name of the db did not work either. I did receive an error though. I attached a file with a screenshot of how my page looks when i type in /admin before the db was renamed. The file also has the error

    Attached Files
  • jrobida999
    Avatar
    Community Member
    10 Posts

    Re: /admin does not go to login page Link to this post

    Well, I'm not sure exactly what happened, except that I'm new to SS and probably just read install docs incorrectly. I did manage to get it fixed though.

    I had a revelation that I had unzipped and copied the ecommerce and payment modules to the root folder of the site. This is when the CMS started failing me. I deleted these 2 directories from the site completely and all is well.

    However, now I need to figure out where/how to implement those items without messing it up again!

    Thanks for your efforts IOTI. It is much appreciated.

    Jake

  • IOTI
    Avatar
    Community Member
    189 Posts

    Re: /admin does not go to login page Link to this post

    Which ecomm module were you using? I'm almost sure none of them work with v3 yet

  • jrobida999
    Avatar
    Community Member
    10 Posts

    Re: /admin does not go to login page Link to this post

    I just downloaded the most current version of the ecommerce module prominently displayed on the extentions page of the site here. That would explain my headache. Thanks for the headsup on that.

  • IOTI
    Avatar
    Community Member
    189 Posts

    Re: /admin does not go to login page Link to this post

    Just found out that http://swipestripe.com/ is now SS3 compatible. I haven't used it, and it's not free but I'd check it out.

    823 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.