Jump to:

23471 Posts in 18937 Topics by 2878 members

General Questions

SilverStripe Forums » General Questions » Trouble Upgrading to 3.0x

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 793 Views
  • JMOR
    Avatar
    Community Member
    12 Posts

    Trouble Upgrading to 3.0x Link to this post

    Currently running I think 3.0,
    Tried to upgrade 3.02, 3.04,3.05

    And it doesn't work.

    I have the install with Saphire.

    Here is what I ddid

    1) Backed up everything inc the DB
    2) Deleted CMS and Sapphire Directory
    3) Upload CMS and Framework.
    4) I get errors

    Am I doing something wrong or is it just trick to upgrade from the non-frame work to framework

    Please let me know what I can do to fix this as I do want the latest security release that is stable...

  • Harley
    Avatar
    Community Member
    153 Posts

    Re: Trouble Upgrading to 3.0x Link to this post

    If you've deleted a directory called "Sapphire" then you must have been running an earlier version like 2.4.7. As of SS3 the Sapphire framework was simply renamed to "framework".

    What are the errors it is giving you?

    Have you removed any modules you have installed? Best to start off clean and then add them back in one by one just in case there are any compatibility issues. You can do so quite easily by renaming the _config.php files in the root of your module folders to something else like "config.php".

    Hope that helps, good luck!

    Regards

  • JMOR
    Avatar
    Community Member
    12 Posts

    Re: Trouble Upgrading to 3.0x Link to this post

    I think I was running 3.0,

    As I do have the tabs and group features and drag an drop

    1) When I re-name the sapphire to framework, which I did it gives me a screen saying server misconfiguration error
    or
    T get part of the site but then it says a page is missing...

  • JMOR
    Avatar
    Community Member
    12 Posts

    Re: Trouble Upgrading to 3.0x Link to this post

    Ok,

    I got it to work, the issue was with Google Analytics.....
    I am going to check if there is an updated version of that.

    Also, my flush was not working all the file for some reascon..

    -Only other issue I am having now is :
    It sends email thorough user forms, but doesn't when I do a password reset, it doesn't send any e-mail...
    ..Thanks...

  • JMOR
    Avatar
    Community Member
    12 Posts

    Re: Trouble Upgrading to 3.0x Link to this post

    I thought I had it, but then i went into the index and changed all sapphire for frame work

    Then I got this page

    http://test.attorneycasetracking.com/index.php

    Do I have to do some programming here; or did I do something wrong in this upgrade test site...

    Warmest,regards
    John

  • JMOR
    Avatar
    Community Member
    12 Posts

    Re: Trouble Upgrading to 3.0x Link to this post

    I changed the link to beta.attorneycasetracking.com

  • JMOR
    Avatar
    Community Member
    12 Posts

    Re: Trouble Upgrading to 3.0x Link to this post

    Any thoughts Guys...

    I get a page now, but it says error processing your request and does show the main page but with errors

    http://beta.attorneycasetracking.com/

    Please help..

    thanks
    John

  • JMOR
    Avatar
    Community Member
    12 Posts

    Re: Trouble Upgrading to 3.0x Link to this post

    I finally got it to work; I had to do a fresh install; and then update the db one by one.
    -My MathSProtection Class is not supported.

    Does anyone have a Math Spam plugin they are working on

    thanks
    John

    793 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.