Jump to:

23367 Posts in 18143 Topics by 2863 members

General Questions

SilverStripe Forums » General Questions » Slow local development with SS3 on mamp

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 349 Views
  • sajok
    Avatar
    Community Member
    82 Posts

    Slow local development with SS3 on mamp Link to this post

    Hello,

    I noticed SS3 is slow on my local development with MAMP, especially when I run ?flush=1 or dev/build, this takes long before I get the result. this was not the case with 2.4 versions of SS.

    Anyone had this issue?

    Saiyd

  • mi3ll
    Avatar
    Community Member
    23 Posts

    Re: Slow local development with SS3 on mamp Link to this post

    Hi sajok,

    Have you tried enabling xcache? It made things much faster for me. Also editing the php ini for more memory might also help (not sure what the default memory limit in MAMP is). You can add the php ini directives to the htaccess file and it should work.

  • feejin
    Avatar
    Community Member
    22 Posts

    Re: Slow local development with SS3 on mamp Link to this post

    MAMP wasn't too bad for me though I had increased PHP memory limit by quite a lot. However, switching to the native Apache server and installing PHP/ MySQL is a lot quicker, in my experience at least.

    349 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.