Jump to:

23007 Posts in 11866 Topics by 2828 members

General Questions

SilverStripe Forums » General Questions » Can't 'Insert Media' in CMS SS 3.0.5 [Solved]

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 286 Views
  • Pix
    Avatar
    Community Member
    120 Posts

    Can't 'Insert Media' in CMS SS 3.0.5 [Solved] Link to this post

    I get an 'Internal Server Error' when trying to use 'insert media' in the CMS, and the pop up is blank. The console spits out:

    GET http://www.urltomytestsite.com/rs3/rs3/admin/pages/EditorToolbar/MediaForm/forTemplate 500 (Internal Server Error) jquery.js:8240
    send jquery.js:8240
    jQuery.extend.ajax jquery.js:7719
    $.entwine.openDialog HtmlEditorField.js:337
    one jquery.entwine-dist.js:1023
    prxy jquery.entwine-dist.js:1048
    $.entwine.openMediaDialog HtmlEditorField.js:320
    one jquery.entwine-dist.js:1023
    prxy jquery.entwine-dist.js:1048
    (anonymous function) editor_plugin_src.js:39
    k.create.execCommand tiny_mce_gzip.php:1
    i.onclick tiny_mce_gzip.php:1
    (anonymous function) tiny_mce_gzip.php:1
    j tiny_mce_gzip.php:1
    y tiny_mce_gzip.php:1

    What's weird is the same server is also running a site using SS 3.0.3 and 'insert media' works fine there.

    Any help would be really appreciated!!!!! This is a tough one and a show stopper.

  • Pix
    Avatar
    Community Member
    120 Posts

    Re: Can't 'Insert Media' in CMS SS 3.0.5 [Solved] Link to this post

    My fault again. I think I had an error in my thumbnail function in a custom image class. Or perhaps it was because there was some bad records for that class hanging around in the file table left there while developing/testing which might explain why the error did not show up when attaching the image to a page, only when trying to use 'insert media' from CMS. Anyway, I fixed the error and got rid of the records which did not actually have an image in assets anymore and the error is gone. Sorry! SilverStripe Rocks!

    286 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.