Jump to:

23361 Posts in 18124 Topics by 2862 members

General Questions

SilverStripe Forums » General Questions » Server Upgrade Woes

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2 3 4 5
Go to End
Author Topic: 2999 Views
  • Lazarus404
    Avatar
    Community Member
    71 Posts

    Server Upgrade Woes Link to this post

    Hey guys,

    So, I've had several SilverStripe websites running on GoDaddy servers for a couple of years with no issues. Then, recently, they decided to update the Apache instance on those servers to version 2.4. Now, when I view the sites, the home pages work great, but all other pages show a 404 error. The admin and dev URLs also show a 404. We've proven that mod_rewrite is working on these servers as is htaccess, as the ModX (yes, I know... I said a swear word) instances work fine.

    Does anyone know what might be the issue, here? Is there anything I can try to get these working? Unfortunately, the servers are shared, so GoDaddy won't let me have access to the Apache config files.

    Thanks in advance,
    Lee

  • Lazarus404
    Avatar
    Community Member
    71 Posts

    Re: Server Upgrade Woes Link to this post

    If it helps to view a site, one of the sites is at http://www.elixair.com

    Thanks,
    Lee

  • Lazarus404
    Avatar
    Community Member
    71 Posts

    Re: Server Upgrade Woes Link to this post

    So, I decided to upload the install script to see if it would help diagnose the issue by stating what was missing or misconfigured on the server. The only anomalie that returned was a message under the PHP configuration which states "magic_quotes_gpc option turned off". It doesn't seem to me like this would be the cause. Could it?

    Any ideas?

    Thanks,
    Lee

  • martimiz
    Avatar
    Forum Moderator
    1067 Posts

    Re: Server Upgrade Woes Link to this post

    Are you able to reproduce this behaviour on a clean straightforward SilverStripe install?

    Does ~elix.... ( dots represents a number) mean anything to you?

    Martine

  • Lazarus404
    Avatar
    Community Member
    71 Posts

    Re: Server Upgrade Woes Link to this post

    Yes, it happens with a fresh install, too. No, I don't recognise ~elix... Where did you see that?

    Thanks,
    Lee

  • Briohny
    Avatar
    Community Member
    199 Posts

    Re: Server Upgrade Woes Link to this post

    Same exact issue with me too. Here's my original post from this morning: http://www.silverstripe.org/general-questions/show/23928#post322510

    I have no idea how to fix and GoDaddy seem to think they haven't changed anything at all. Let me know if you have any progress. I'll keep looking for a fix too.

  • martimiz
    Avatar
    Forum Moderator
    1067 Posts

    Re: Server Upgrade Woes Link to this post

    Lazarus404: it looks like for every page except for the homepage, silverstripe is looking for URLSegment" = '~elixXXXX'. I don't know why, does that seem right to you, or ring a bell?

    (XXXX represents a number that I didn't want to expose here - but it's always the same number.)

    Pop me a mail if you want me to explain how I got there...

    Martine

  • Lazarus404
    Avatar
    Community Member
    71 Posts

    Re: Server Upgrade Woes Link to this post

    Yes please, Martimiz. I can't find that in the page source. elix... is probably the account directory name. If I knew where that was being displayed, it might be I could piece together what the problem is.

    GoDaddy still hasn't resolved the issue. They've admitted it's their fault, but doesn't seem to be making this a priority.

    Thanks,
    Lee

    2999 Views
Page: 1 2 3 4 5
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.