Jump to:

23007 Posts in 11866 Topics by 2828 members

General Questions

SilverStripe Forums » General Questions » Porting to live server

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 231 Views
  • vinstah
    Avatar
    Community Member
    2 Posts

    Porting to live server Link to this post

    Hi I just want to know the easiest way to go from a working development server (LAMP) to a live server (LAMP) with SS 3.0.5 CMS

    I have read the other members' posts and followed them i have tried:

    1. Installing a fresh copy to my root directory on the live server (public_html) with an empty database (_SS)
    2. Exporting the tables in the development servers database and then importing into live database after dropping those tables
    3. Copying mysite folder, templates and assets to the live server replacing everything
    4. Editing mysite/_config.php $db array to suit
    5. then doing /dev/build

    after doing that I am left with a site that doesn't show any created pages that were in the Dev server.
    if I go to the CMS in pages it shows home but no created pages

    Also tried copying all files over from Dev server and changing mysite/_config.php to suit then importing database to live server

    Is there anything I am missing? or any step by step guide

    thanks,
    vinnie

  • Willr
    Avatar
    Forum Moderator
    5464 Posts

    Re: Porting to live server Link to this post

    Double check your database import / export worked and was for the correct database!

    231 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.