Jump to:

22999 Posts in 11854 Topics by 2828 members

General Questions

SilverStripe Forums » General Questions » Home Page Theme

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 273 Views
  • DavidD
    Avatar
    Community Member
    4 Posts

    Home Page Theme Link to this post

    Could someone point me in the right direction? I had my site built by a third party and of course they are no longer around. My sites home page seems to be missing the theme files or someting. All other pages work just not the home page. For example /inventory or /about-us as well as /admin

    Attached Files
  • IOTI
    Avatar
    Community Member
    187 Posts

    Re: Home Page Theme Link to this post

    Did this just happen recently? What is working in the past and then just suddenly stopped working? Have you made any changes to the code or templates?

  • DavidD
    Avatar
    Community Member
    4 Posts

    Re: Home Page Theme Link to this post

    Yes, just recently happened (godaddy hosted). All was working fine and no changes have been made.

    http://www.redapplehay.com (broken)

    http://www.redapplehay.com/inventory (working as well as all other pages.)

  • cSGermany
    Avatar
    Community Member
    37 Posts

    Re: Home Page Theme Link to this post

    It looks like that the css rules were not applied.

    Did you change the class and / or id names in your html markup of the homepage template?

  • DavidD
    Avatar
    Community Member
    4 Posts

    Re: Home Page Theme Link to this post

    No, no changes have been made on this site for some time that is what is confusing.

  • IOTI
    Avatar
    Community Member
    187 Posts

    Re: Home Page Theme Link to this post

    DavidD,

    I noticed that on your homepage, all of links in your nav menu contain index.php/. As does your base href meta tag, but the subpages do not.

    Do you have FTP access to this site? If so, can you check and make sure that index.php is still in the root of your SilverStripe directory?

  • DavidD
    Avatar
    Community Member
    4 Posts

    Re: Home Page Theme Link to this post

    Yes index.php was there... Your post caused me to look closer at index.php and what I found was this...

    define('BASE_SCRIPT_URL','index.php/');

    So I changed it to

    define('BASE_SCRIPT_URL','');

    This fixed my problem! Don't understand what changed to cause this but thanks for your help!

    273 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.