Jump to:

22999 Posts in 11854 Topics by 2828 members

General Questions

SilverStripe Forums » General Questions » silverstripe 3.1 performance time to first byte

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 327 Views
  • Guy Van Bael
    Avatar
    Community Member
    28 Posts

    silverstripe 3.1 performance time to first byte Link to this post

    Hi,

    Since 3.1 i'm comparing load times of pages and they are signifantly slower then page load times in 2.4.
    All code in the templates is optimized, gzip compression on, minified css and js....

    It's especiall the "time to first byte" that causes te waiting time... (an average of 3,5 second!).

    Is there anybody here who can shine a light on this?

    Thanks
    Guy

  • Bambii7
    Avatar
    Community Member
    254 Posts

    Re: silverstripe 3.1 performance time to first byte Link to this post

    Did you make a silverstripe-cache folder inside the project directory?
    I know it was running slow for me until I made this folder.

  • Guy Van Bael
    Avatar
    Community Member
    28 Posts

    Re: silverstripe 3.1 performance time to first byte Link to this post

    Hi,

    Solved it with partial caching the menu loop. Site had a rather large sitetree. Without the partial caching. Menu was recreated with every page load using php.

    Partial caching solved it. We have normal loading times now.

    guy

    327 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.