Jump to:

23369 Posts in 18155 Topics by 2863 members

General Questions

SilverStripe Forums » General Questions » Trouble uploading pictures to the file manager

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 290 Views
  • haugen
    Avatar
    Community Member
    12 Posts

    Trouble uploading pictures to the file manager Link to this post

    I have a site in production. It was upgraded from 3.0 to 3.1, and moved from a test server to a production server, with different domains.

    Now, I cannot upload files. When I'm in the file manager, the "drop file here" doesn't show, and no errors are given. I haven't logged errors and warnings yet, this is dumb. I will do it after this post and update it with my findings. But, when I change the environment type from live to dev, the "drop file here" appears, and I'm allowed to upload files. The Assets folder was copied from the 3.0 installation and synced. It has the appropriate permissions.

    A /dev/build has been run.

    In advance, thanks for the reply!

    Update: No errors logged.

  • Bereusei
    Avatar
    Community Member
    94 Posts

    Re: Trouble uploading pictures to the file manager Link to this post

    Did you check the file permissions from the assets folders? Chmod of every folder and subfolder in assets/ must be 777.

  • haugen
    Avatar
    Community Member
    12 Posts

    Re: Trouble uploading pictures to the file manager Link to this post

    The assets folder and its content does not have 777, and that they must be 777 is false. 755 with apaches user as owner should be sufficient.

    Thanks for the suggestion, though

  • haugen
    Avatar
    Community Member
    12 Posts

    Re: Trouble uploading pictures to the file manager Link to this post

    Anyone else experience something similar, or know what's up? Much appreciated. I don't want to manually upload files for my client forever. Maybe I should try reinstalling Silverstripe.

    290 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.