Jump to:

23490 Posts in 18996 Topics by 2878 members

General Questions

SilverStripe Forums » General Questions » Can't upload files

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 267 Views
  • evjan
    Avatar
    Community Member
    7 Posts

    Can't upload files Link to this post

    Hi,

    I have a 3.1.2 website and I can't upload images (png or jpg, or any file type for that matter) to it, I get a "Forbidden" message in a black popup on the top right.

    When I go to the file manager in SS I can create folders and delete files, so it seems to be isolated to uploads only.

    Also, it works like a charm when I try it locally on my dev machine.

    Here's what I've tried:
    - adding a 'upload_tmp_dir = "./tmp"' to php.ini
    - setting permissions to /tmp and /assets to 0777 recursively

    Any other ideas?

  • Bambii7
    Avatar
    Community Member
    254 Posts

    Re: Can't upload files Link to this post

    sounds like you've tried the likely culprits. I did come across a Red Hat server that would get grumpy when files or folders were set to 0777, it wanted them as 644 or something. Might be worth a try.

  • evjan
    Avatar
    Community Member
    7 Posts

    Re: Can't upload files Link to this post

    I tried setting it to 644 on tmp and assets and other combinations, but to no avail.

    Any other ideas? It's weird that I have other SS sites on the same host (albeit running older versions of SS) and they work like a charm in this respect.

    267 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.