Jump to:

23379 Posts in 18298 Topics by 2867 members

General Questions

SilverStripe Forums » General Questions » multisites possible?

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
Go to End
Author Topic: 17578 Views
  • Brasil
    Avatar
    Community Member
    12 Posts

    Re: multisites possible? Link to this post

    Is it not better to keep the themes folder local (so not as a symlink) as in this folder you place the site specified template?

  • adanso_239
    Avatar
    Community Member
    1 Post

    Re: multisites possible? Link to this post

    @ UncleCheese Can you kindly send me your script for creating the multiple sites I work for a school district and this would greatly help us create the high school, elementary school and middle school websites utilizing your script my email address is adanso239@gmail.com thank you.

  • wildflower1975
    Avatar
    Community Member
    59 Posts

    Re: multisites possible? Link to this post

    Hi Juanitou

    when you say

    -Copy also the .htaccess file (after installing the SS3 environment) and modify the RewriteBase directive.

    what should the RewriteBase Directive be?

    I'm getting a lot of "Failed opening required File" because it's not on the Include path,

    I'm sure something (apache or PHP) needs to put a / on the end of the include paths to find the required files but I'm not sure how to tell it that

    my .htaccess has :

    <IfModule mod_rewrite.c>
    SetEnv HTTP_MOD_REWRITE On
    RewriteEngine On
    RewriteBase '/'

    RewriteRule ^vendor(/|$) - [F,L,NC]
    RewriteRule silverstripe-cache(/|$) - [F,L,NC]
    RewriteRule composer\.(json|lock) - [F,L,NC]

    RewriteCond %{REQUEST_URI} ^(.*)$
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_URI} !\.php$
    RewriteRule .* framework/main.php?url=%1&%{QUERY_STRING} [L]
    </IfModule>

    my site directory is in /var/www/mysite
    and framework is in /var/www/ss3/framework and cms /var/www/ss3/cms

    the symlinks are working and the _ss_environment.php in /var/www/mysite is being read and working

    cheers

    EDIT:

    it looks like it stems from having my BASE_PATH set incorrectly by blindly copying somebody else's statement above

    my one has one less dirname() call
    define('BASE_PATH', rtrim(dirname($_SERVER['SCRIPT_FILENAME']), DIRECTORY_SEPARATOR));

    I think I'm using SS 3.1.3 - I can't tell which because composer doesn't say (or I don't know how to ask it)
    the silverstripe_version files in the framework and cms dirs are blank

    When I try to sue symlinks for cms and framework (to ../ss3/framework) I end up with a
    PHP Fatal error: Cannot redeclare class Zend_Cache in /var/www/nzia/framework/thirdparty/Zend/Cache.php on line 28

    So I don't know if this is in the Autoloader manifest twice somewhere or what

    17578 Views
Page: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.