Jump to:

23376 Posts in 18218 Topics by 2867 members

General Questions

SilverStripe Forums » General Questions » Modifying Alt Attribute in Images

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1188 Views
  • geisha64
    Avatar
    Community Member
    5 Posts

    Modifying Alt Attribute in Images Link to this post

    I noticed when I do "insert image", the alt attribute is missing from img tag:
    <img class="left" src="assets/Uploads/SilverStripeLogo.png?r=59381" hspace="null" vspace="null" width="424" height="376" align="null" >

    It has other attributes that I don't need such as hspace, vspace, and class. Is there a workaround so that when I do an "insert image", it will automatically insert the alt tag?

    From searching thru the forum and the documentation, it looks like the only method to update an image alt attribute is via the HTML in the Content Editor. Is this the case or am missing something?

  • Liam
    Avatar
    Community Member
    470 Posts

    Re: Modifying Alt Attribute in Images Link to this post

    Ya, in 2.2.x it handled it pretty badly with the extra garbage code.

    In 2.3 it's all cleaned up and working like expected.

    1188 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.