Jump to:

23491 Posts in 18996 Topics by 2878 members

General Questions

SilverStripe Forums » General Questions » Am I using translatable?

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 979 Views
  • clburkins
    Avatar
    Community Member
    4 Posts

    Am I using translatable? Link to this post

    Hi All, I set up a test site for a client who needs a site that's both in Spanish and English. Following some instructions somewhere on the SS site, I put this into my _config.php:
    i18n::enable();
    This seemed to mostly work. I could sort of create translations using the "Translations" tab.

    When I do this, am I using the "Translatable" module that's not quite ready for prime time in SS 2.3? The reason I ask is that that Translations Tab is now giving me a "Server Error" when I try to create a Spanish translation. My client is getting nervous and asking if we should change CMS's, so I'm wondering whether I can expect a bug fix for this with a maintenance release.

    Thanks for any help you can give me!

  • clburkins
    Avatar
    Community Member
    4 Posts

    Re: Am I using translatable? Link to this post

    I've added a little more detail to my question, and therefore I'm bumping.

  • micahsheets
    Avatar
    Community Member
    164 Posts

    Re: Am I using translatable? Link to this post

    I am having this exact problem. When I select a language and click the create button I get the Server Error in red at the bottom of the CMS page. The site was running using the Trunk version from a few weeks prior to the 2.3 being released. I upgraded from the old Truck to version 2.3 release version.

  • HenryE
    Avatar
    Community Member
    6 Posts

    Re: Am I using translatable? Link to this post

    I was just wondering if anyone out there has had any success with translations?

    I have recently installed 2.3.1, and am getting the javascript parse error when I click on the button to create a translation in the translations tab. I have also been unable to find any info on how to set up the translations. Any pointers would be much appreciated.

  • banal
    Avatar
    Community Member
    901 Posts

    Re: Am I using translatable? Link to this post

    Hello all

    I'm not part of the SilverStripe dev. team, but here's what I know:
    Translations (eg. Multilingual Sites) don't work in 2.3.0 and 2.3.1. See this blog post (somewhere near the bottom of the page):
    http://silverstripe.org/silverstripe-2-3-0-released-1000s-of-improvements/

    Apparently, this should be fixed in 2.3.2, have a look at the bug-tracker:
    http://open.silverstripe.com/query?group=status&component=i18n&milestone=2.3.2-rc1

    According to the roadmap (http://open.silverstripe.com/roadmap), a first release candidate of 2.3.2 is scheduled for April 24th.
    Solution for now: Use 2.2.x

    HTH

  • HenryE
    Avatar
    Community Member
    6 Posts

    Re: Am I using translatable? Link to this post

    Hi banal,

    Thanks heaps for the info. Much Appreciated.

    H.

    979 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.