Jump to:

23355 Posts in 17734 Topics by 2862 members

General Questions

SilverStripe Forums » General Questions » 2.3 Problem with Linking in TinyMCE

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1346 Views
  • xcommum
    Avatar
    Community Member
    10 Posts

    2.3 Problem with Linking in TinyMCE Link to this post

    Myself and a colleague of mine have updated to ver 2.3 of silverstripe (over top 2.2) which was successful. When I go to add a link to some content and click on the "link" button in tinymce it works for me, however when my colleague does this same process he gets a insert link error. The errors are shown here that he receives. I dont know why only he is getting these errors, and want to know how to resolve for his side. Any help appreciated!

    Error Messages:
    Website Error There has been an error The website server has not been able to respond to your request.

    [User Error] Object::__call() Method 'insert' not found in class 'Form' POST /admin/EditorToolbar/LinkForm Line 133 in /public_html/sapphire/core/Object.php

  • Willr
    Avatar
    Forum Moderator
    5482 Posts

    Re: 2.3 Problem with Linking in TinyMCE Link to this post

    Are you both using the same browser?

    It could be that the JS file is cached on his machine (still from 2.2). So try emptying the browsers cache and then visiting the cms

  • mandrew
    Avatar
    Core Development Team
    32 Posts

    Re: 2.3 Problem with Linking in TinyMCE Link to this post

    You aren't the only person seeing this error. I have created a ticket http://open.silverstripe.com/ticket/3716 so you can see the progress we are making on this bug.

  • xcommum
    Avatar
    Community Member
    10 Posts

    Re: 2.3 Problem with Linking in TinyMCE Link to this post

    Thanks guys. It seems like when I reverted back to 2.2 it took the linking error away so that fixed that, but we still get a header error message saying:

    [User Error] Object::__call() Method 'insert' not found in class 'Form' POST /admin/EditorToolbar/LinkForm Line 133 in /public_html/sapphire/core/Object.php

    Any new progress on this error?

    1346 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.