Jump to:

23355 Posts in 17734 Topics by 2862 members

General Questions

SilverStripe Forums » General Questions » Problem expanding and contracting pages in the CMS

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 2357 Views
  • fishe
    Avatar
    Community Member
    42 Posts

    Problem expanding and contracting pages in the CMS Link to this post

    I have a site with around 30-40 pages under a parent in the CMS. At some point SS stopped letting me expand or contract up the hierarchy. It now only expands if I add a new page under it (i.e. clicking on the parent and adding a new page).

    Any ideas here?

    A known issue?

  • Willr
    Avatar
    Forum Moderator
    5482 Posts

    Re: Problem expanding and contracting pages in the CMS Link to this post

    Any more details? What Browser and SilverStripe version are you using?

  • Howard
    Avatar
    Community Member
    215 Posts

    Re: Problem expanding and contracting pages in the CMS Link to this post

    This issue popped up for me as well, in firefox to be able to expand the sitetree I have to select "Allow drag and drop reordering". Then it works as expected- the site is now live so I am going to wait until the next stable before I update it. I have started a ticket on trac for this bug http://open.silverstripe.com/ticket/3737

  • Howard
    Avatar
    Community Member
    215 Posts

    Re: Problem expanding and contracting pages in the CMS Link to this post

    This issue popped up for me as well, in firefox to be able to expand the sitetree I have to select "Allow drag and drop reordering". Then it works as expected- the site is now live so I am going to wait until the next stable before I update it. I have started a ticket on trac for this bug http://open.silverstripe.com/ticket/3737

  • fishe
    Avatar
    Community Member
    42 Posts

    Re: Problem expanding and contracting pages in the CMS Link to this post

    Sorry willr...forgot important details...I've updated the ticket started by howardgrigg

    (FX 3.1b3, OS X)

    It's working fine in Safari 4 beta.

  • Fuzz10
    Avatar
    Community Member
    787 Posts

    Re: Problem expanding and contracting pages in the CMS Link to this post

    Yeah , I noticed this as well. It seems the problem is isolated to Firefox 3.1 (or , 3.5 as it is called from now on)..

    Since Mozilla is still working hard on their new javascript engine I don't think it is worth fixing silverstripe to run with a beta version of Firefox.. All other big browsers work for me (safari/chrome/IE)...

  • bratpak
    Avatar
    Community Member
    2 Posts

    Re: Problem expanding and contracting pages in the CMS Link to this post

    I am also having this issue BUT it is happening with all browsers...
    and I can not find a work around...
    I tried a few sugestions in this post but nothing worked...
    it just sits there saying loading and flashed the error "error loading subtree"
    has anybody found a solution?

  • Fuzz10
    Avatar
    Community Member
    787 Posts

    Re: Problem expanding and contracting pages in the CMS Link to this post

    bratpak ..

    It seems you have a different problem ... The one in FF3.1 is java-script specific bug in the user-interface. Your problem sounds more serious .. ;-(

    Can't help you with that though , sorry.

    2357 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.