Jump to:

23491 Posts in 18996 Topics by 2878 members

General Questions

SilverStripe Forums » General Questions » Site defaulting to login page.

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1476 Views
  • designerdre
    Avatar
    Community Member
    19 Posts

    Site defaulting to login page. Link to this post

    Rather than displaying the homepage of the website when the homepage URL is requested it redirects to /Security/login. Instead of spending hours poking around I'm hoping that someone would be able to graciously give me the guidance that is needed here.

  • banal
    Avatar
    Community Member
    901 Posts

    Re: Site defaulting to login page. Link to this post

    Hi.
    I'm not sure if;
    a) You're trying to get Security/login to show up whenever somebody visits your home-page. Or...
    b) Your problem is, that Security/login shows up where your home-page should be.

    To solve a)
    You could change your home-page to a redirector page (Behaviour tab), pointing to Security/login.

    To solve b)
    Have a look at the "Access" tab of your home-page. Do some restrictions apply there?

    Best - Roman

  • designerdre
    Avatar
    Community Member
    19 Posts

    Re: Site defaulting to login page. Link to this post

    Thanks a million! My problem was (b) and your suggestion worked. Thanks again.

  • Junglefish
    Avatar
    Community Member
    104 Posts

    Re: Site defaulting to login page. Link to this post

    I'm having the same problem (ie. b above), but my access tab settings seem fine. Where else can I look?

    jf/

  • 1k2k3
    Avatar
    Community Member
    15 Posts

    Re: Site defaulting to login page. Link to this post

    try doing and it will recreate the homepage.

    http://localhost/silverstripe/dev/build

    Also look into index.php file within the SilverStripe Directory.

  • Junglefish
    Avatar
    Community Member
    104 Posts

    Re: Site defaulting to login page. Link to this post

    Hi 1k2k3

    I have already tried re-building several times, but no joy there.

    Can you tell me which index.php you are referring to? There isn't one directly in the SilverStripe directory.

    jf/

  • 1k2k3
    Avatar
    Community Member
    15 Posts

    Re: Site defaulting to login page. Link to this post

    So If you delete "home" you will get an error. If you then flush the database it will recreate a "home" page.

    http://localhost/silverstripe/dev/build/?flush=1

    After flushing the database, change the page type of the homepage in the CMS, under the “Behaviour” tab. Change it to HomePage, and click “Save Draft” and “Publish”.
    reference: http://doc.silverstripe.org/tutorial:1-building-a-basic-site

    Well my silverstripe has an Index.php file inside the root directory, I'm not sure whether or not its relevant I was just saying you could give it a go. But I'd recommend flushing your DB and then recreating a new homepage.

    Attached Files
  • Junglefish
    Avatar
    Community Member
    104 Posts

    Re: Site defaulting to login page. Link to this post

    Hi again

    Yep, in fact that's what I had to do - destroy my old homepage and recreate a new one. Why would I have to do this? I'm still not sure. I took a look in the database to see if there was something odd about the old record but nothing stood out.

    So, for me, case closed, but I'm not really much the wiser...

    jf/

    1476 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.