Jump to:

23377 Posts in 18296 Topics by 2868 members

General Questions

SilverStripe Forums » General Questions » Blank Site all of a sudden

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1214 Views
  • Double-A-Ron
    Avatar
    Community Member
    604 Posts

    Blank Site all of a sudden Link to this post

    Hi all,

    I've inherited a Silverstripe problem from someone else. Version 2.2.3. Last week the site was functioning fine, and there is no info on what happened since then to cause this issue.

    The issue is that we get a blank page on every single URL we try. I have tried setting the site into dev mode in config, and using isDev=1 in the URL. (neither will show the login box so I can login anyway). So I can view no errors. Same thing happens when trying to go to the CMS - blank page.

    We have a standard .htaccess file. And a php index file responds fine if we comment out the line: RewriteRule .* /sapphire/main.php?url=%1&%{QUERY_STRING} [L].

    I have gone through main.php and added a die('debug'); command to see if I can trace the problem and was able to confirm that the problem occurs at a command near the bottom:

    Director::direct($url);

    I have done a db/build/?flush=1 - output is fine, nothing repaired or reported.

    I have cleared cache and done a normal flush on multiple urls.

    I have checked my appache error logs in real time and every time a page on this site is loaded, I get the following error:

    [notice] child pid 9922 exit signal Segmentation fault (11)

    Any further ideas? I've completely run out except for re-installing completely, which will be a major.

  • Fuzz10
    Avatar
    Community Member
    787 Posts

    Re: Blank Site all of a sudden Link to this post

    Huh ? Is apache/php crasing

    Did you try the codebase on a different server ?

  • Double-A-Ron
    Avatar
    Community Member
    604 Posts

    Re: Blank Site all of a sudden Link to this post

    It appears so.

    I did try a few other things since my first post:

    1. Upgrade Sapphire, CMS and Jsparty to 2.3.1. This kinda worked and the site was viewable again, although there are now a few issues in the CMS. (Tabstrips are dissappearing)

    2. Download a fresh copy of 2.2.3 and replace Sapphire, CMS and Jsparty with the files from that archive. Blank page problem occurs instantly.

    3. I noticed that this installation also has 3 modules: blog, something calles "SSP", and something called "filemanager". With 2.3.1 basecode installed, I removed filemanager as per a previous post from someone having the same problems in the CMS after upgrading. This works, however now the blog doesn't. Gets and error about "SimplePie" class not being present.

    Basically, I think the previous developer has borked this site with untested modules. I think filemanager is the HasMany file manager that I have seen in the forum. No idea what SSP is.

    Still looking for ideas. As it stands, the site functions with an upgrade to 2.3.1 and removing filemanager, but the client loses functionality they claim was working, and the blog doesn't seem to be compatable with 2.3.1.

    BTW. The hosting server has not changed.

    Cheers
    Aaron

  • Fuzz10
    Avatar
    Community Member
    787 Posts

    Re: Blank Site all of a sudden Link to this post

    I chose to replace the filemanager with UncleC's dataobjectmanager ; it is a 10 minute job , but the client will need to add the files all over.

    However ; although the module development is stopped ; Banal did release a fix to make it work with SS 2.3 ; check out :
    http://www.silverstripe.org/all-other-modules/show/251371?start=8

    The blog module needs to be upgraded to the latest version , you might need to alter some templates for it to work , but it shouldn't be too much of a pain in the *ss....

    SSP module.. No idea what that means..... What is in it ? Did you look at the code ?

    1214 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.