Jump to:

23002 Posts in 11855 Topics by 2828 members

General Questions

SilverStripe Forums » General Questions » Confusing Error Page Behavior

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 520 Views
  • micahsheets
    Avatar
    Community Member
    164 Posts

    Confusing Error Page Behavior Link to this post

    I know that to get the 404 page not found error page working you have to change the urlsegment to "404". However it makes no sense to me why the system will auto generate an error page during a dev/build but you have to go in and change the page to make it work. Also once you change the urlsegment, another dev/build will auto generate another page-not-found page that I have to delete each and every time.

    It seems to me that since the error page is auto generated at dev/build and often with templates that are unfinished as they are in the development stage, maybe a better way could be made.

    At the end of a project when a site is going to go live I always have to open up the 404.html page in assets and manually fix tons of errors and issues. I would rather have a button or an action like ?generate404=1 that will make the error page when I am ready to make it.

    Of course it is possible that I am missing something important here and the way it is being done may be better than my proposed way.

    520 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.