Jump to:

23377 Posts in 18296 Topics by 2867 members

General Questions

SilverStripe Forums » General Questions » Upload image within TinyMCE not working

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 3604 Views
  • blair
    Avatar
    Community Member
    9 Posts

    Upload image within TinyMCE not working Link to this post

    I am wanting to find out how to upload an image from within the editor (TinyMCE) in Silverstripe 2.3.0.

    When I click on the 'Upload' link in this frame it does nothing:

    I have tested this in Firefox 3 and Internet Explorer 6 and 7. It does not work in any of them.

    Any help in getting this working would be much appreciated.

  • PGiessler
    Avatar
    Community Member
    47 Posts

    Re: Upload image within TinyMCE not working Link to this post

    You have to choose the folder, because without choosing a folder you aren't able to upload files.
    If you selected the folder, maybe there is a bug in your SilverStripe Version. The Upload is based on Ajax, so every browser can handle this request. So you should update your version!

  • blair
    Avatar
    Community Member
    9 Posts

    Re: Upload image within TinyMCE not working Link to this post

    Sorry, yes I did choose a folder before clicking Upload.

    I suspect that this may be a bug, but I have not been able to find evidence of anyone else having an issue with it. Upgrading to 2.3.1 may fix it, but the upload function doesn't work for me on http://demo.silverstripe.com either (not sure which version of Silverstripe the demo uses).

    Does this button work for anyone else?

  • blair
    Avatar
    Community Member
    9 Posts

    Re: Upload image within TinyMCE not working Link to this post

    I raised this with Silverstripe Support and it turns out it is because the library used for uploading files (SWFUpload) doesn't support Adobe Flash version 10. This is detailed in the following bug: http://open.silverstripe.com/ticket/3023

    By downgrading my Flash to version 9 I was able to get the upload function to work correctly.

  • patte
    Avatar
    Community Member
    63 Posts

    Re: Upload image within TinyMCE not working Link to this post

    Thanks much for that info!

    I did have the same problem - now I downgraded to Flash Player 9 and the image upload works fine ;-)

    Adobe Website: Archived Flash Players available for testing purposes

    Flash Player 9 (166 MB)

    • flashplayer9r151_win.exe (Flash-Installer für Netscape, Mozilla, Firefox)
    • flashplayer9r151_winax.exe (Flash-Installer für Internet Explorer)
    • flashplayer9r151_win_sa.exe (Flash-Installer für Flash Standalone)

  • Anibe
    Avatar
    Community Member
    1 Post

    Re: Upload image within TinyMCE not working Link to this post

    If you are using Firefox 3 and you don't want to go through the pain of downgrading Flash, you can simply disable Flash from the browser and the upload will work.

    To disable flash in Firefox 3+ goto Tools > Add-ons > Click on Plugins tab.

    Scroll down the list and you should see "Shockwave Flash" and the right button to disable it

    3604 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.