Jump to:

22993 Posts in 11829 Topics by 2827 members

General Questions

SilverStripe Forums » General Questions » Using SS on a local computer under XAMPP

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 893 Views
  • jimw
    Avatar
    Community Member
    13 Posts

    Using SS on a local computer under XAMPP Link to this post

    I was not sure where to post this question, so I chose here. The installation went okay. I built some pages and they were fine. Then I added the Event Calendar and got that to work after I figured out the discrepancies between the documentation and the code. Then it was suggested to add the dataobject_manager. I tried and failed. When I ran the dev/build, I get the error:

    [Notice] Use of undefined constant PHP_URL_PATH - assumed 'PHP_URL_PATH'
    GET /SilverStripe/dev/build

    Line 54 in D:\Program Files\xampp\htdocs\SilverStripe\sapphire\dev\DebugView.php

    In fact, when trying to add the forms module, I get the same thing. Can anyone tell me the cause of this and the solution? Is this a quirk when running locally? Would I have the same problem if I install this on my host?

    Just trying to learn so I can actually use SS for my main web site.

    Thank you, jim

    893 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.