Jump to:

22977 Posts in 11742 Topics by 2826 members

General Questions

SilverStripe Forums » General Questions » Images with links have blue borders .. help!

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1444 Views
  • aidanodr
    Avatar
    Community Member
    13 Posts

    Images with links have blue borders .. help! Link to this post

    Hi Guys,

    I have an SS site in the process of being built:

    http://www.netactivesolutions.net/stripe/client-list/

    At this page you might note that the GO THERE! images on right have a blue border around them. I have a link inserted to these images. In "normal" html one can remove this link by setting Border="0" in the link code BUT it is not allowed in SS.

    Is their any place this can be sorted? Is it a CSS issue? Is it a Tinymce CSS issue?

    Any ideas, I want to dump that blue border?

    I SHOULD SAY - this issue seems to only appear in INTERNET EXPLORER.

    Aidan

  • CrazyCoders
    Avatar
    Community Member
    32 Posts

    Re: Images with links have blue borders .. help! Link to this post

    Almost at the top of your CSS put this rule:

    img { border: 0px; }

  • aidanodr
    Avatar
    Community Member
    13 Posts

    Re: Images with links have blue borders .. help! Link to this post

    Spot on Crazycoders, sorted - thanking you.

    One more thing I notice in IE7 and NOT in Opera or Firefox is just under the left menu box its like a very thin "repeat" of the menu box graphic is appearing, just cannot figure out why?

    Aidan

  • CrazyCoders
    Avatar
    Community Member
    32 Posts

    Re: Images with links have blue borders .. help! Link to this post

    Can't help if you don't stop moving the menu code around, please put it back like it was and i'll help you else, i'll have to let you fix it yourself! I've been waiting for 10 minutes refreshing from time to time but the menu keeps changing...

  • aidanodr
    Avatar
    Community Member
    13 Posts

    Re: Images with links have blue borders .. help! Link to this post

    Sorry about that,

    Was just trying to fix it - no go.

    ME LEAVING IT ALONE now

    All yours,
    Aidan

  • CrazyCoders
    Avatar
    Community Member
    32 Posts

    Re: Images with links have blue borders .. help! Link to this post

    I can't really test but the first thing that jumps to my eye is the enormous amount of white space and the use of a background-image to do the top and bottom...

    Why not simple do this:

    <div id="menu">
    <div id="topofmenu"><img src="topofmenu.jpg" /></div>
    <ul>
    <% control Menu(1) %>
    <li><a href="$Link">...</a></li>
    <% end_control %>
    </ul>
    <div id="bottomofmenu"><img src="bottomofmenu.jpg" /></div>
    </div>

    This would be the most beautiful way of doing it and by far the most efficient on all browsers!

  • aidanodr
    Avatar
    Community Member
    13 Posts

    Re: Images with links have blue borders .. help! Link to this post

    Thanking you again,

    I managed to get rid of that repeat anomally by adding a < br > to just before the rounded graphic at the bottom of the menu:

    </br>   
    <div id="sidebarbot"><img src="../stripe/themes/brushedsilver/images/leftmenubot.jpg" /></div>

    Strange one
    Aidan

  • CDGIDev
    Avatar
    Community Member
    9 Posts

    Re: Images with links have blue borders .. help! Link to this post

    Something is still wrong with your layout... It now looks nice in IE7 but IE8 is all strange... Firefox is still ok!

    1444 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.