Jump to:

23490 Posts in 18996 Topics by 2878 members

General Questions

SilverStripe Forums » General Questions » Cant do a db/build

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 739 Views
  • b0bro
    Avatar
    Community Member
    38 Posts

    Cant do a db/build Link to this post

    Hi, ive copied an old clients site down to my local machine. Trying to do a db/build?flush=1 (Older version of SS) and i get the following error.

    user_error(Disallowed action: 'db' on controller 'ErrorPage_Controller',256)
    line 121 of Controller.php

    Controller->run(Array)
    line 22 of ModelAsController.php

    ModelAsController->run(Array)
    line 104 of Director.php

    Director::direct(/latinRetreatsRio/db/build/)
    line 159 of main.php

    Any Ideas?? I can copy the database and the site seems to run. But ill be buggered if i can do a db/build??

  • Hamish
    Avatar
    Community Member
    712 Posts

    Re: Cant do a db/build Link to this post

    try dev/build?flush=1 - this is the new URL.

  • b0bro
    Avatar
    Community Member
    38 Posts

    Re: Cant do a db/build Link to this post

    Thanks hamish, I was only using db/build because its a early version 2.2.3

    NOW TRYING TO UPDATE..

    new development. Running dev/build?flush=1 i just get "Creating Database Tables" and nothing else!!!

    I dont even get an error!

    Try to look at my site and i only get the white screen of death!
    The site has multi languages and wondering if this has something to do with it??

    Please help. I require the latest SS version so must figure this out.

  • banal
    Avatar
    Community Member
    901 Posts

    Re: Cant do a db/build Link to this post

    A white screen usually means you got errors in your PHP code. Have a look at the PHP Error log. You should find the cause of your problem there. If you don't have access to the PHP Error log, maybe this helps: http://doc.silverstripe.com/doku.php?id=debugging

  • b0bro
    Avatar
    Community Member
    38 Posts

    Re: Cant do a db/build Link to this post

    thank you, i had no idea about debugging and have been annoyed all this time that i couldnt see what was going on.

    739 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.