Jump to:

23456 Posts in 18905 Topics by 2877 members

General Questions

SilverStripe Forums » General Questions » Problem saving and publishing

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 949 Views
  • mschiefmaker
    Avatar
    Community Member
    187 Posts

    Problem saving and publishing Link to this post

    I am having a problem (primarily on a mac) where the save and publish will work to begin with and then at some point it hangs and just keeps cycling on save and publish (but the green saving indicator on the LHS never shows). Shutting down all occurances of this type of the browser (I can still be attached in a different browser) clears the issue and I can save again until the problem reoccurs which seem to be pretty regular.

    Refreshing the browser will always cause the issue to occur.

    I am running 2.3.2. Have tried a suggestion from a previous thread of adding GoogleSitemap::DisableGoogleNotification(); to mysite/_config but this fails with th message
    Fatal error: Call to undefined method GoogleSitemap::disablegooglenotification() in /home/anzata/public_html/mysite/_config.php on line 29
    and I understand from another thread that GoogleSitemap was not included in 2.3.2 hence why the method is undefined but this means the issue must be elsewhere

    Any ideas what would cause this problem, the site is on a test server with a host Is there anything that might be in its set up that could cause the problem?

    I am desperate on this onee as the go-live is the end of next week but at the moment very little work is being achieved as itkeeps hanging

    Thanks

    MM

  • mschiefmaker
    Avatar
    Community Member
    187 Posts

    Re: Problem saving and publishing Link to this post

    Have had the server setup checked but it is all above the requirements. Can anyone suggest a soution this obviously makes Silverstripe unusable? While I am not having to many problems saving, another user is now getting the same issue on a PC.

    thanks

    Catherine

  • mschiefmaker
    Avatar
    Community Member
    187 Posts

    Re: Problem saving and publishing Link to this post

    I am also having problems creating new table using a mac - the only way to create one is by writing it is in HTML. I have logged a seperate thread for his but I can't help wondering if this is caused by the same problem so I would thought I would mention

  • Bruce B
    Avatar
    Community Member
    145 Posts

    Re: Problem saving and publishing Link to this post

    I hit problems with save and publish not working recently - the 'Saving' message never goes away. In my case it was because I was creating a large user-defined form that exceeded the PHP memory limits on the server. To manage that particular form, I had to copy the database to my Macbook Pro, where I had much higher PHP memory limit, fix the page, then load the database back onto the server.

    Not a nice process but it has only happened for this particular circumstance. In your case, I'm guessing that the Save failure is related to time in use rather than particular pages but it might be worth checking the PHP memory limit on your server.

  • mschiefmaker
    Avatar
    Community Member
    187 Posts

    Re: Problem saving and publishing Link to this post

    Hey Bruce

    Thanks for your response. It certainly does sound like the issue. In the install specs it says to set the maximum memory to at least 48 mb - I assume this is what you are talking about but please correct me if I wrong I don't know a lot about set up of servers.

    When you sayincreasing this do you have any suggestions to how much?

    thanks

    Catherine

  • mschiefmaker
    Avatar
    Community Member
    187 Posts

    Re: Problem saving and publishing Link to this post

    The hosting provider has come back and said the memory limit is set to 64M.

  • mschiefmaker
    Avatar
    Community Member
    187 Posts

    Re: Problem saving and publishing Link to this post

    Upgrading to 2.3.3 has fixed the issue.

    949 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.