Jump to:

23377 Posts in 18296 Topics by 2867 members

General Questions

SilverStripe Forums » General Questions » cannot view site after repointing domain name?

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 728 Views
  • podge
    Avatar
    Community Member
    6 Posts

    cannot view site after repointing domain name? Link to this post

    Hi there,

    I've already installed my silverstripe site to a temporary URL provided by by webhost. Everything works fine at this location, but when i pointed the domain name (to go live) to my silverstripe installation, it shows as a 404. I can access oher test files in the root folder, so its pointed at the right location. Is there anything else i need to do to get the site to appear under the live domain name - update URLs or similar?

    any help appreciated!
    tks

  • dalesaurus
    Avatar
    Community Member
    283 Posts

    Re: cannot view site after repointing domain name? Link to this post

    Make sure your .htaccess is in place in your webroot

  • podge
    Avatar
    Community Member
    6 Posts

    Re: cannot view site after repointing domain name? Link to this post

    hey thanks for the reply. I got this sorted. It was a combination of 2 things.
    1. Even though i had pointed the domain name to the name servers, the domain host hadn't switched off a redirect in their "Value Added Services" ??. That was messing up my view of the site.

    Once that was removed, i was able to run the "rewritetest.php" in the root, and it worked a treat. Finally site live!

    tks again

    728 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.