Jump to:

23367 Posts in 18143 Topics by 2863 members

General Questions

SilverStripe Forums » General Questions » Error Uploading Assets

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 2053 Views
  • sca123
    Avatar
    Community Member
    61 Posts

    Error Uploading Assets Link to this post

    When uploading assets using swfupload, the upload is successful and the CMS returns "Success" however the file is not uploaded to the directory and the CMS registers the file name as "new-file"

    Can anyone help me with this issue?

  • bellafaith
    Avatar
    Community Member
    12 Posts

    Re: Error Uploading Assets Link to this post

    I'm having this problem too. It was working on test server, but once I uploaded to new server (in which I did upgrade Silverstripe from 2.3.3 to 2.3.6) I'm getting the new file problem too.

  • Ben_W
    Avatar
    Community Member
    80 Posts

    Re: Error Uploading Assets Link to this post

    I had some problems with Assets folder before, it could be related to file permissions.
    after initial installation of the SilverStripe, you should have /Assets/Upload/ folder in the file structure, and it is required to have write permissons. From this point onwards, any new image folder or file folder you created using SilverStripe's CMS are belonged to the server, in my case, they are owned by 'apache:apache'. This means, if you move your site from your dev server to live server, always remember to keep the file permission. If you use ftp client to upload to the live site, then the folder as well as the files will have the permission of your ftp log-in permission, which is most likely not the server permission. That is why sometime, you know the files are there, however you just can't access them.

    What I usually do is tar the entire dev site to preserve the file permission, upload to live server and then untar it. Another the way is upload a file using SilverStripe, make sure it works, then check it's permission so that you know what is your server permission, next you just need to chown all the files in the /Assets/Upload, and the folder under /Assets/

    Hope this may help.

  • bellafaith
    Avatar
    Community Member
    12 Posts

    Re: Error Uploading Assets Link to this post

    My problem was the value of upload_tmp_dir in my client's php.ini. I posted my solution in this thread.

    2053 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.