Jump to:

23473 Posts in 18941 Topics by 2878 members

General Questions

SilverStripe Forums » General Questions » Additional params for uploaded flash

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2 3
Go to End
Author Topic: 4335 Views
  • Piet Golf
    Avatar
    Community Member
    6 Posts

    Re: Additional params for uploaded flash Link to this post

    Banal: i used your solution having a flash page inside my webssite. Running the site gives "swfobject is not defined"; i can't figure out why this is happening. Any idea how to solve this? btw i installed silverstripe 2.4 and just started a couple of days ago to het used to it

    Thanks,
    Piet Golf

  • banal
    Avatar
    Community Member
    901 Posts

    Re: Additional params for uploaded flash Link to this post

    Hi Piet

    Are you sure the swfobject.js file is being loaded? How did you include it? Using Requirements::javascript()?
    I suggest you use FireBug to see if the file loads or not.

  • Piet Golf
    Avatar
    Community Member
    6 Posts

    Re: Additional params for uploaded flash Link to this post

    Hi Banal,

    I was using Firebug and i got the message "swfobject is not defined".

    I followed the instructions as published at ssbits.org (Embed flash content using SWFObject) but maybe i have to add an include somewhere. Keep in mind that i just started using silverstripe so it can be that i missing something that's obvious for an experienced user.

    Thanks,

    Piet

  • banal
    Avatar
    Community Member
    901 Posts

    Re: Additional params for uploaded flash Link to this post

    Does swfobject.js show up in the Net Tab of Firebug? I.e. is it being loaded?

  • Piet Golf
    Avatar
    Community Member
    6 Posts

    Re: Additional params for uploaded flash Link to this post

    swfobject.js does not show in Net tab of Firebug. I added also a flash in one of my photo albums and that flash is showing without any problem.

  • Piet Golf
    Avatar
    Community Member
    6 Posts

    Re: Additional params for uploaded flash Link to this post

    When i checked the html code there is no doctype etc for the page where swobject.js is not loaded. Maybe this will help?

    I was using theme BlackCandy but switching to theme Tutorial (putting FlashPage.ss in themes/tutorial/templates) i didn't got the problem with swobject.js. So it must have something to do with the theme and i will investigate further. Your help is still very welcome.

  • sergieboy
    Avatar
    Community Member
    33 Posts

    Re: Additional params for uploaded flash Link to this post

    Works fine. But still one question ; where do I have to place the skin file ?
    In the proposed solution, the flash file plays without a skin. I tried every possible location.
    Normally you have to place the skin file at the same location as the swf file to play.
    Doesn't work.

    Any ideas ?

    4335 Views
Page: 1 2 3
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.